Results 1 to 7 of 7

Thread: Some help please

  
  1. #1
    Status
    Offline
    Pete13's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Some help please

    Hi everyone
    Sorry my first thread is asking for help (promise ill introduce myself when I get sorted).
    I have a 53 plate eco4 diesel and had it for 2 months and done 2000 miles.
    Eerything going great till this afternoon when the battery light came on and the power steering stopped working. (crikey have you tried to drive one without power steering!)
    Ive checked the fluid level no problems there, ive also checked and the belt seems fine.
    Someone tells me the power steering pump is on the back of the alternator which could explain the battery light illumination.
    i'm not very technically minded and wondered if you kind folks could nail a diagnosis for me in order that I don't get ripped of at a garage.
    Thanks for any suggestions.
    Pete

  2. #2
    Status
    Offline
    Pete13's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Gentle bump

  3. #3
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    gentle move to the electrical forum

    welcome to AOC btw


    sounds like you alternator is on it's way out, as the PAS is usually first to suffer

  4. #4
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Agree with the above
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  5. #5
    Status
    Offline
    Pete13's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks guys, sorry for the noob posting in the wrong place!

  6. #6
    Status
    Offline
    astrasx1's Avatar
    AOC Regular
    Join Date
    Jul 2006
    Posts
    231
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi and welcome to AOC

  7. #7
    Status
    Offline
    Tinker's Avatar
    AOC Regular
    Join Date
    Jan 2008
    Posts
    269
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Had this problem on a MK4 Astra, turned out the alternator had gone Id get it checked quick as what happened to my car was it was first intermittant then before I knew it car had totally lost all power and it ended up on the back of a tow truck!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •