Results 1 to 6 of 6

Thread: Air Con fault

  
  1. #1
    Status
    Offline
    sassi the cat's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Air Con fault

    Hi i have an Astra 2001 16v sxi had it a few years and the air con has never worked. i've had it checked for gas etc and was told there is no problems there but was told i had "faulty pump" and would cost around £400 to fix. i have now heard that these very rarely go and it could be something as simple as connection or fuse. the aircon light does come on and all my heating works fine also the car stays very cool when running short and long distances.

    are there any tests i could do to determin a problem/fix also is there a fuse for the aircon?

    with summer coming i would like it working this year ;o)

    thanks Kerry

  2. #2
    Status
    Offline
    Ruperts Trooper's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,471
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    AFAIK -

    the aircon pump may leak through it's seals needing continual regassing (or replacement)

    the aircon pump gets noisy as it wears but if you can stand the noise it seems to go on cooling for ever, well 40k miles in our case, after the noise starts.

    the electrics in the aircon pump clutch drive can fail - no cooling at all would be the symptom.
    Maintains:- Vectra Design 1.9CDTi
    Drives :- Hyundai Santa Fe


  3. #3
    Status
    Offline
    ieatyouup's Avatar
    AOC Regular
    Join Date
    Feb 2007
    Posts
    197
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had similar probs when i purchased my coupe, have a look at my previous threads it was the engine coolant module. about £100

    not even vauxhall could diagnose it, they changed all sorts with no luck, was my mechanic that sorted it

  4. #4
    Status
    Offline
    sassi the cat's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i've had the car since 16k miles it now has 38k the aircon hasnt worked at all since i had it so i dont get any noise from it

  5. #5
    Status
    Offline
    sassi the cat's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Ruperts Trooper View Post
    AFAIK -

    the aircon pump may leak through it's seals needing continual regassing (or replacement)

    the aircon pump gets noisy as it wears but if you can stand the noise it seems to go on cooling for ever, well 40k miles in our case, after the noise starts.

    the electrics in the aircon pump clutch drive can fail - no cooling at all would be the symptom.
    i have no noise coming from it at all i press the switch it does nothing i've had the car since 16k miles it has 38k now and didnt work when i got it.

  6. #6
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    Chances are the AC compressor (pump) isn't the part at fault but the clutch that engages it, they end up burning out

    This can be tested by checking power to the wiring with the engine running and switching the AC on and off
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





Similar Threads

  1. 2003 Astra 1.6 Active - Fault after fault...
    By lightfoot256 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 12
    Last Post: 28-07-2011, 11:17
  2. Temp gauge fault, 2 Fault codes
    By Autosparks in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 29-11-2008, 17:22
  3. 18XE1 coilpack - is a fault always shown by fault code?
    By oddsocks in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 05-11-2007, 22:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •