Results 1 to 6 of 6

Thread: Z20LET burning oil 2l/1000km

  
  1. #1
    Status
    Offline
    ghostrider's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z20LET burning oil 2l/1000km

    Guys, please help and advice. I am using GM 5w/30 and it uses like 2l/1000km. Some guys said it should be engine but it has only 50k on the clock. No blue smoke on idle, and very limited amount when reving it to the top.

    Any ideas and expiriences? Has someone work on the engine(pistons,...) and on what mileage, what about symptoms?

  2. #2
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    Could be lots of things to be honest,Do you have any mods? i'm sure GM state that 1ltr per 1000 miles is acceptable but yours is double that, plus from my experience the 5/30W oil is just to thin for Z20let engine (Just my opinion don't want this to turn into another oil thread battle) My engine likes the GM 10/40 stuff. Check your boost pipes first for oil you should have no more than a thin coating within the pipes, any more than that e.g it drips out then you could have a tired turbo which may need replacing. also check all your breather pipes for blockages or kink's in pipework. Don't think it would be piston rings on that milage.

  3. #3
    Status
    Offline
    ghostrider's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Car do not have any mods. How much oil do your car use per 1000km? I am definetly planing to go with different oil and semy syntethic but thinking to change even brand to go with Mobil or something. When you say check boost pipes, do you mean on that large and long rubber pipe or the ones that are directly conected to the turbo? Do you have some picture as explanation?

    Thanks for everything anyhow...

    Regards

  4. #4
    Status
    Offline
    SRi-Andy's Avatar
    AOC Fanatic
    Join Date
    Feb 2006
    Posts
    590
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ghostrider - Do a search on threads started by Oilman. His posts are not only informative but extremely useful
    Europa Blue Astra Coupe Turbo

  5. #5
    Status
    Offline
    Coupe John's Avatar
    AOC Obsessed
    Join Date
    Aug 2007
    Drives
    Astra 1.9 cdti xpack
    Location
    Leeds
    Posts
    2,593
    Mentioned in
    17 Post(s)
    Quoted
    61 Post(s)
    First check the long rubber pipe which goes from top of intercooler to throttle body, two clips and its off, then check the bottom intercooler pipe this goes to turbo you may need to take the bumper off to gain access, if oil pours out of the bottom of the intercooler you have a broken turbo for sure as for your question on how much oil my car uses I would say around a qtr of a litre every 1000 miles.

  6. #6
    Status
    Offline
    ghostrider's Avatar
    AOC Newbie
    Join Date
    Feb 2008
    Posts
    6
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks guys, will check it in Saturday since it is only non working day for me and will let you know the result...

Similar Threads

  1. z20let oil burning off
    By nebster81 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 1
    Last Post: 08-09-2010, 20:54
  2. Z20let Oil burning problem...please help!!
    By MrGSI in forum Turbo Petrol Engines inc. Transmissions
    Replies: 10
    Last Post: 16-04-2007, 23:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •