Results 1 to 4 of 4

Thread: Front speaker / amp help

  
  1. #1
    Status
    Offline
    ryanbaker's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    45
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Question Front speaker / amp help

    Hi

    Before christmas i wired up my standard coupe speakers to an amp knowing i was gonna buy some new speakers. got some infinity components, fitted them in the doors, all was working fine. going round a roundabout last week there was a loud thud noise from speakers and they stopped working, they were working fine the next time i got in car though. thought it was a lose connection so checked all these yest, now amp powers up, speakers thud, light on amp turns from green to red and no sound. what could this be? ive checked all connections and cant work it out.
    Black 1.8 16V Coupe, De-Restricted & K&N Filter, 18" BK299, Lowered on KW Springs and Shocks, Irmscher Grill, Spoiler, De-Badged, Tinted Indicators, Light brows, DVD & Screen, Boot Build.

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    It sounds like it's going into protection mode

    Have you had both door panels off and checked your wiring going to the speakers?
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    Coo's Avatar
    Banned
    Join Date
    May 2003
    Posts
    25,105
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Amp is going into protection mode....check for a short somewhere in the amp wiring...

  4. #4
    Status
    Offline
    ryanbaker's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    45
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    No ive not had door panels off, think this may be where the problem is.

    Cheers for quick replies
    Black 1.8 16V Coupe, De-Restricted & K&N Filter, 18" BK299, Lowered on KW Springs and Shocks, Irmscher Grill, Spoiler, De-Badged, Tinted Indicators, Light brows, DVD & Screen, Boot Build.

Similar Threads

  1. Front Speaker Depth?
    By thebigstu in forum ICE Mk5|H
    Replies: 3
    Last Post: 12-02-2011, 20:45
  2. Front speaker problems
    By grl69 in forum ICE Mk4|G
    Replies: 3
    Last Post: 18-01-2010, 14:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •