Results 1 to 5 of 5

Thread: 2.0 DTI acceleration?

  
  1. #1
    Status
    Offline
    kyle_dlk's Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    2.0 DTI acceleration?

    Right i have a 2.0DTI. Recently i have noiced that it isnt responding well to acceleration. When you floor the throttle its seems to take a second before you feel it kicking in?? Anyone know what could be the problem here? Its not a major worry and i know some smart person will tell me all thats wrong is its a diesel lol but it definately used to respond well to acceleration!

  2. #2
    Status
    Offline
    Steve Y20DTH's Avatar
    AOC Regular
    Join Date
    Dec 2007
    Posts
    99
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mileage? When was it last serviced? Oils and filters.

    It could be the air fow meter. Mine had only done 34k when i got it and it was having a few problems. They changed the the AFM and WOW it was quick after that.
    Hi

  3. #3
    Status
    Offline
    scouceget1's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    505
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi can you help me my y20dth is slow from the standing start but the acceleration is twitchy seems to hesitate

  4. #4
    Status
    Offline
    AstraDti16v's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    1,688
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Is it at all revs that it does this? Any specific gear? See if you get the same problem if you use 3/4 throttle, i bet its alot better.
    .. 2.0 Dti 16v ..
    .. With a few mods ..

  5. #5
    Status
    Offline
    scouceget1's Avatar
    AOC Fanatic
    Join Date
    Mar 2008
    Posts
    505
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers astra dti only seems to be in low gears the hesitation and the slow pick up

Similar Threads

  1. Z20LET bogging down under light acceleration, fine under hard acceleration
    By LeeMk4Turbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 04-09-2012, 11:31
  2. Need More Acceleration!!!!
    By C4M3R000N in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 18-06-2007, 10:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •