Results 1 to 3 of 3

Thread: Astra Mk 4 Problem

  
  1. #1
    Status
    Offline
    andrewp's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra Mk 4 Problem

    Can anyone help?

    My Astra Mk4 is playing up. The engine mangement light keeps coming on, it's now staying on and car has little power. If I press on the accelerator it flashes on and off then goes back to on. I've had it to a garage and they said something like valve number two not firing and suggested the Ignition Coil Pack be replaced. This was replaced today and the same thing is happening, money down the drain so far!!

    EGR valve was replaced about 6 months ago which fixed that problem of not always starting. Car alway starts first time, I really don't know what to do now, does anyone have any ideas?

  2. #2
    Status
    Offline
    jackocoupe's Avatar
    AOC Regular
    Join Date
    May 2004
    Posts
    269
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If the engine light is staying on then the car is put in a safe mode to reduce engine damage if there is a problem. I can only suggest taking it to vauxhall and they can plug it in to find the fault.

    or if you know anyone who works for the AA they have the same fault finding software on there laptops.

  3. #3
    Status
    Offline
    andrewp's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by jackocoupe View Post
    If the engine light is staying on then the car is put in a safe mode to reduce engine damage if there is a problem. I can only suggest taking it to vauxhall and they can plug it in to find the fault.

    or if you know anyone who works for the AA they have the same fault finding software on there laptops.
    Thanks, thing is I paid local garage £30 to check the fault, this is what they suggested I change, they said if this doesn't fix it they'll need to delve into the engine!! They said it had fixed it but 10 mins later and it's back. I am just scared incase it's one thing after another!

    Forgot to mention that it flashes every time I press the accelerator, does it flash to tell you it has found a problem because every time I touch it, it flashes. Sometimes I can turn it on and do a little run and it'll be fine.

Similar Threads

  1. 53 Astra LS CDTDI Astra Battery Charging problem
    By HMFC in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 28-01-2011, 17:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •