Results 1 to 3 of 3

Thread: Z20LET knocking on cold start up!

  
  1. #1
    Status
    Offline
    kg_turbo's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,268
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Z20LET knocking on cold start up!

    Anyone know what this might be?

    Knocks until about 30secs after it has idled, worse when revved but then disappears!! Is this the start of something big or a simple fix?
    Please help me before my warranty runs out on me
    Zaffy VXR on the beat

  2. #2
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Could be one of many things but what springs to my mind is big/little ends worn or a lazy oil pump not getting the oil around quick enough.

  3. #3
    Status
    Offline
    kg_turbo's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,268
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thats what im worried about as Ross aka Daddygsicool had his bottom end go and it was new engine time!!

    Any other ideas before i take it back to vauxhall again?

    Had a new vxr turbo and rocker assembly 1800 miles ago

    Was knocking before this work was done tho!
    Zaffy VXR on the beat

Similar Threads

  1. Brilliant on cold start... not so good on warm start
    By micklep in forum Diesel Engines inc. Transmissions
    Replies: 65
    Last Post: 19-12-2012, 22:23
  2. Engine automatically 'pulses' the revs when idling (warm start, not cold start)
    By bobmoo79 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 22-04-2010, 10:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •