Page 1 of 5 12345 LastLast
Results 1 to 10 of 44

Thread: How to locate and clean EGR valve in 2001 Astra 1.7 DTi

  
  1. #1
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Exclamation How to locate and clean EGR valve in 2001 Astra 1.7 DTi

    Hi all

    A new member here with the following issue on my Y reg 2001 Vauxhall Astra 1.7 DTI LS 16V ECO4 with 145 K miles:

    Smoke during acceleration, especially uphill: Replaced glowplugs recently, regularly serviced with new air filter, oil/ fuel filters etc.

    Also at high rpms (aroung 3000) while cruising on motorway (speed of 85 MPH+), the MIL light comes on sometimes (which I think could be related to smoke at high rpm) as I can see smoke through the mirror from the lights of cars behind me. I've a feeling that the turbo has stopped and car is driving like a naturally aspirated diesel at those times...

    The acceleration used to be superb in my car buts its slowed a little bit recently but MPG is still very good...

    I was thinking to check/ clean EGR valve and then MAF/ MAP sensors.
    Any guide on where to find these on Astra and then clean them? None of these have ever been cleaned/ changed on my car.

    Thanks for your help in advance..

  2. #2
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Still no replies... could some technical people please help?

    I've had my car serviced since my last post with new air, oil and fuel filter and new 5W40 havoline synthetic oil. I've also put Glynn's oil treatment additive into in.

    NOW the big ISSUE is that every now and then the MIL lamp is coming on. It did not come on straight after service but on the next day and its been intermittent since then. The car has been less smoky than before but could MIL be due to smoke going beyond some threshold value?
    Can the CAT/ EGR be cleaned?

    I hope that the diesel filter is fitted OK (right way), it was a traninee guy who changed it. I know they are self bleeding these days. Could MIL lamp come on due to some filter not put in correctly?

    I've checked all hoses and they are tight..

    I was thinking of buying a tech2 from e-bay for about £20 and then doing the code read through my laptop. Should I do that?

    Would be really thankful for any help.. thanks in advance..

  3. #3
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Just fit a new AFM. Pretty likely that's your problem.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

  4. #4
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks ZS

    Could you highlight how to change Air Flow Meter as simple steps. Would the MIL light (which is staying solid ON for today) go off or would I need the tech2 after change to clear the light?

    Would it be worth checking/ cleaning EGR valve? Are they easy to locate on my car?

    Cheers...

  5. #5
    Status
    Offline
    Scottyboy's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,750
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The MIL light will go off once the new AFM is installed and you have driven a few miles (assuming that is what the problem is).

    It is very easy to change -

    With ignition turned off remove the multi connector from the old AFM
    Undo the two large hose clips securing the AFM (you may need to buy some new worm drive ones as you will probably destroy the GM ones when you take them off if the AFM has never been changed before)
    Remove the old AFM, fit new one into the pipes and secure with clips
    Reconnect the multi-connector
    Drive car

  6. #6
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah, it's pretty much two jubilee clips and a plug. Just make a note of which way the arrow on the body of the AFM is pointing.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

  7. #7
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks so much for your reply guys..

    The MIL stayed off for a week and it came back on today.

    The worst part is there is quite a bit of power loss in the form of power lag in picking up regardless of MIL. The turbo lag is worse now and sometimes turbo does not come on at all..
    The car seems a little bit smoky as well when pushed hard.. NO starting issues though. The MIL light either comes on at start or does not come on at start. No change in its status during drive (if ON stays ON; if OFF stays OFF).

    Are these symptoms pointing to AFM?
    I am buying a tech 2 from e-bay and might get an AFM from there too...

  8. #8
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'm 99% sure it's the AFM now.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

  9. #9
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks, checked e-bay, they are around £40 inc delivery. Are they also called MAF sensor? I will order one and report back after installing it.

    Cheers ZS..

  10. #10
    Status
    Offline
    ksareen's Avatar
    AOC Newbie
    Join Date
    Jan 2008
    Posts
    60
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi all

    Changed the air flow meter. Driveablility has def improved a bit. However, to my dismay the MIL came back on after 1 day. As said before, I think the car is a bit smoky as well (when you look through the mirror into the light of car behind you at night).. And I can confirm its black smoke (leaving black carbon on floor when you push the acc pedal hard at idle)..

    The MIL has gone off again but its doing that ON-OFF behaviour for the past 2 weeks now..
    I've bought tech2 now, so would update again with the codes..

    Thanks for your guidance...

Page 1 of 5 12345 LastLast

Similar Threads

  1. where is the idle control valve on a 2001 astra ?
    By kb 88 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 2
    Last Post: 02-09-2012, 09:39
  2. Any guides anywhere on how to locate and clean an AFM Sensor, 2000 Astra 1.7td?
    By plantpot50 in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 06-09-2009, 21:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •