Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No Power!! Please Help!!

  
  1. #1
    Status
    Offline
    wayne'o''s Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    No Power!! Please Help!!

    Hi to all, i am brand new to aoc and like to say a big hello to everyone.

    I have a 2000 (X) astravan dti with 80k on clock

    Im in need of some of help and ideas, a couple of months ago the turbo failed and the engine started to rev its brains out with the keys out of the ignition in my hand still reving. It stopped before it sized but on restart was clearly off compression. A mechanic friend and I started to dismantle the engine, removed right down to pistons and found it had picked up on number 1 piston. Bought 1 new piston, new shells, rings, headgasket, cam belt, turbo and rad, and put it back together.

    Started up with no problems ticks over fine, on test drive though is where the problem is, it is absolutley gutless any kind of a hill and its 1st gear, revs are very slow to build up even standing still, no warning lights on, no unusual emmisions. had it on code reader, no faults, tried loads of parts off same style van, air flow metre, vacume, exhaust, checked timing twice with no results.

    Any help or ideas would be gratley appreciated, sorry for a long first post but its starting to bother us that we cant sort it.

  2. #2
    Status
    Offline
    jonsey's Avatar
    AOC Fanatic
    Join Date
    Nov 2007
    Posts
    365
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like you had an airlock in your fuel system, did you run it dry at some stage? anyway, the dti`s rely heavily on the turbo for most of its power delivery, i would start with all hoses in and around the immediate area, if your sure its running sweet, then there cant be much wrong with your rebuild, you will loose shed loads of getupandgo if your turbo aint happy.

  3. #3
    Status
    Offline
    Daddygsicool's Avatar
    Club Team
    Join Date
    Apr 2006
    Posts
    2,133
    Mentioned in
    7 Post(s)
    Quoted
    0 Post(s)
    welcome its a jungle in here

    sorry carnt help with the problem
    Arden Blue Zafira Gsi

  4. #4
    Status
    Offline
    wayne'o''s Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hi jonsey, thanks for the ideas, never ran it dry on fuel at anytime but like you i first thought it was a fuel problem checked it out and it seems fine.(bottom crank pulley lined up and both bolts in the injector pump pulley and cam shaft pulley) I have a feeling its something to do with the turbo or actuator got these off ebay for £225 brand new with 6 months warranty, i've checked all pipes around turbo even removed them and checked turbo is free enough, all seems fine.

    thanks for the welcome daddygsicool

  5. #5
    Status
    Offline
    wayneGSI's Avatar
    East Midlands RO
    Join Date
    May 2007
    Posts
    3,973
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    welcome to the site
    like daddygsicool i cant help either
    Astra GSi Turbo
    dap-performance.co.uk
    Live in the East Midlands?

  6. #6
    Status
    Offline
    Bokee's Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    15
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi,
    looks like your car running with fuel and oil mix...
    if you see a big smoke then you did something wrong with pistons and rings....
    check compression of every piston....
    if there are no smoke then check all fuel line,throttle or fuel filter.
    did you try to change the fuel filter or check a accelerator pedal....
    EGR maybe.....

    Hope this helps,
    Regards

  7. #7
    Status
    Offline
    wayne'o''s Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi Bokee

    Thanks a lot for the ideas, there is no big smoke but i will do a compression test just in case, i have changed the fuel filter and the accelerator pedal EGR seems ok, i have noticed that it pulls slighlty better when its warmed up (but still no where near what it should pull like). It also does'nt seem to have that normal diesel (rattley) noise that they have (seems quieter), so i was going to advance/retard the diesel pump a tooth either way to see if this makes much difference. before i do this i will check the fuel lines though.

    thanks again for the ideas.

    Hi to wayneGSI and thanks for the welcome

  8. #8
    Status
    Offline
    Bokee's Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    15
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hmmmmmm....
    Try diagnostic test....some errors maybe...
    One more thing: if there too much errors,then car going to "limp mode".
    Try to disconnect the battery over night to reset ECU.Maybe "fly" tomorrow...who knows...

    Good luck

  9. #9
    Status
    Offline
    wayne'o''s Avatar
    AOC Newbie
    Join Date
    Dec 2007
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    maybe compression test might bring up something, i will also try removing battery

    thanks a lot for the help

  10. #10
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    how longs it been run in for? as diesels can be quite tight at first, also what oil are you using as you may need thiner oil while its run in again
    ARDEN BLUE GSI

Page 1 of 2 12 LastLast

Similar Threads

  1. Supplying power to drls from two power sources - astra Sri 2006 1.9
    By markfordham in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 31-08-2014, 23:30
  2. Matzel power power box info needed
    By Kev_mk3 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 13-12-2005, 10:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •