Results 1 to 6 of 6

Thread: Where's the Coolant/Temp Sensor?

  
  1. #1
    Status
    Offline
    david_a's Avatar
    AOC Newbie
    Join Date
    Apr 2006
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Where's the Coolant/Temp Sensor?

    hi,

    Ive got this blasted Engine Coolant light on the dash (square box with a fan symbol in it) which flashes intermittently, sometimes is on, sometimes is off, and seems to pop up mostly when its wet or when the cars been for a good thrashing :-)

    I think its a problem with the engine coolant/temp sensor(s) as ive checked the cootant levels, oil, and anything else which I can think of.

    Can anyone offer advice and tell me what's going on, or tell me where these sensors are please on a 2.2 16v Astra G Sri??

    cheers, Dave

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    More likely to be a problem with the cooling system ECU or at least within the system itself..... of course the CTS is a very cheap replacement so maybe its worth a shot

    Personally Id get it checked out at the dealers or at least a similar garage with diagnostic equipment who can "try" and diagnose the fault

    I know on all the other 16v engines its located on the bottom left of the head looking from the front....just down from the rad top hose..... as for the 2.2 location I aint got my haynes on me so cant check

    Im sure sum1 will be along soon to clarify...should at least be near to the top hose/thermostat housing

  3. #3
    Status
    Offline
    david_a's Avatar
    AOC Newbie
    Join Date
    Apr 2006
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers for that, I'll take a look in the morning around the area you said, hopefully I'll find it.

    I do know that the AirCon has a leak or something, as it was regassed a while ago and ran out in less than a month, but im not too bothered about that, just need to get this light out so I can sell it without something obvious being wrong.

    I think it must be the sensor as its been going on for months, and nothing else has gone wrong

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if u know the aircon is problematic then thats most likely the reason for the light....the light is only fitted to models with aircon therefore one would assume its related to your aircon leak etc...

    Might be worthwhile getting the leak fixed - would be much better in the long run selling a car with working AC than one with not....at least get it looked at

    Id go as far as to say the CTS has nothing to do with the light whatsoever....good luck anyway

  5. #5
    Status
    Offline
    david_a's Avatar
    AOC Newbie
    Join Date
    Apr 2006
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    now here's something strange, i hadnt managed to do any checking yet the light has now gone off. it must be a faulty sensor!

    can anyone shed any light on what could be the problem? im looking to sell the car soon, and dont want this coming on the dash in the middle of a viewing!

    cheers

  6. #6
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Well get it checked out then - a TECH2 hookup at vauxhall will probably be able to tell u whats at fault.

    The problem relates to the Aircon and as said before the CTS is very unlikely to have anything to do with it.

    If u know youve got an AC leak then thats what the light is for,,,,,on a side note, would u buy a car which u knew to have an AC leak? I know I wouldnt,,,,Id rather shop around to find one that worked.....maybe it would be in ur own interest to have it fixed.....

Similar Threads

  1. P0115 - coolant temp sensor malfunction _ where's the sensor? (z20let)
    By mike0491 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 31-03-2014, 22:57
  2. Asta h pollen, outdoor temp sensor, coolant sensor locations please
    By Jattxx in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 13-01-2011, 23:42
  3. Coolant control module or coolant temp sensor?
    By andrewdevlin86 in forum Electrical
    Replies: 5
    Last Post: 20-04-2010, 18:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •