Results 1 to 2 of 2

Thread: CO emissions control X16XEL

  
  1. #1
    Status
    Offline
    bimmer49's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    CO emissions control X16XEL

    On idle, my car has passed its test but on raised engine speed the CO level raises gradually from 0.479 to as high as 0.880 which is a fail. All other measurements remain within allowances. It has new plugs, lambda sensor and CAT. I also ran it on 98 octane with Inj. cleaner and rechecked it with an engine temperature at 100 deg. but no better. Diagnostics enquiry gives " either a lost connection to the ecu or a sensor not responding" result. Fat lot of good that is ( I have replaced the engine loom too). Anyone know what device would control this?

  2. #2
    Status
    Offline
    bimmer49's Avatar
    AOC Newbie
    Join Date
    Nov 2007
    Posts
    3
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Thumbs Up

    After plenty of asking and credit to a Rumanian mechanic (GG) here in Spain who suggested disconnecting the ECU temp. sensor in the head and then taking it for test, my car has another 12 months of test. It appears that if you disconnect this sensor, the ECU resets to default mapped values and restrict fueling but not to the extent that it affects driving. However, a side effect is when on warm start up the car will idle on high revs (1500) until the throttle is pushed and the ECU takes over with better engine info.

Similar Threads

  1. MOT emissions fail, X16XEL
    By monkeyairms in forum Astra Discussion & Chat
    Replies: 13
    Last Post: 10-04-2012, 11:35
  2. Astra F X16XEL Emissions.
    By bimmer49 in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 14-05-2010, 18:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •