Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Astra GSI issue

  
  1. #1
    Status
    Offline
    michty_me's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra GSI issue

    Hi All,
    I have been reading around the site for a couple of months now and am impressed with whats happening.
    I have a little problem myself to be honest. About 6 months ago I purchased an Astra GSi and everything is great, however after a few months I noticed the idling
    was a bit wonky sometimes. When I was idling it would sometimes drop to around 200rpm and my engine lights would come on. So I stuck it into vauxhall to get it checked out.
    They said it was an easy fix and just had it marked down as a field remedy(Think it had something to do with boost pressure adjustment)
    This problem has not re-occured but they said that they checked out the whole car and said I had a leaking exhaust manifold gasket and that I would be losing power from this. When I picked it up from vauxhall and was driving it home, I was able to feel the second boost kicking in (or what felt like it) at around 4000rpm.
    Also if i keep my foot on the accelerator at around 3500-4000RPM then it feels like its miss firing or losing gaining power rapidly or jerking. Hard to describe. I thought this could have been the exhaust manifold.
    This was a month or so ago. Just got the manifold gasket repaired the other day and the misfiring and feeling of the second boost arent as bad now but still there.
    Do you think it is possible that it could be another leak elsewhere? My local garage think it could be a spark plug breaking down at roughly the same load but im not sure.
    Anyone had similar problems to my issue.
    To my knowledge the only mod's are a bailey dump value and stainless exhaust from CAT back.


    Sorry for the long post!

  2. #2
    Status
    Offline
    michty_me's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    GSi Issue

    Hi All,
    I have been reading around the site for a couple of months now and am impressed with whats happening.
    I have a little problem myself to be honest. About 6 months ago I purchased an Astra GSi and everything is great, however after a few months I noticed the idling
    was a bit wonky sometimes. When I was idling it would sometimes drop to around 200rpm and my engine lights would come on. So I stuck it into vauxhall to get it checked out.
    They said it was an easy fix and just had it marked down as a field remedy(Think it had something to do with boost pressure adjustment)
    This problem has not re-occured but they said that they checked out the whole car and said I had a leaking exhaust manifold gasket and that I would be losing power from this. When I picked it up from vauxhall and was driving it home, I was able to feel the second boost kicking in (or what felt like it) at around 4000rpm.
    Also if i keep my foot on the accelerator at around 3500-4000RPM then it feels like its miss firing or losing gaining power rapidly or jerking. Hard to describe. I thought this could have been the exhaust manifold.
    This was a month or so ago. Just got the manifold gasket repaired the other day and the misfiring and feeling of the second boost arent as bad now but still there.
    Do you think it is possible that it could be another leak elsewhere? My local garage think it could be a spark plug breaking down at roughly the same load but im not sure.
    Anyone had similar problems to my issue.
    To my knowledge the only mod's are a bailey dump value and stainless exhaust from CAT back.

    Sorry for the long post and if it appears suddenly else where. I tried posting earlier but couldnt find it again once it submitted.

  3. #3
    Status
    Offline
    K3FUS's Avatar
    AOC Obsessed
    Join Date
    Nov 2004
    Posts
    5,752
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It could be many things and a forum is not the most accurate diagnosis tool, but some of your sysmtoms sound like AMM (air flow meter) failure.

    They normaly put the management light on, but not always. Irregular ideling and poor performance are symptoms.

    It's best to get it to a garage for further investigation.
    Tell me what you've done, not what you're going to!

  4. #4
    Status
    Offline
    gsi-jay's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,049
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be a plug or the coil pak breaking down or the gap wrong in a plug and basically the spark is being blown out wiv the pressure
    courtney stage 3 zafira,Mitsubishi evo geek mapped to 389 and 470 lb of torque

  5. #5
    Status
    Offline
    Enigma ???'s Avatar
    AOC Obsessed
    Join Date
    Jul 2007
    Posts
    2,468
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It could be the DV as well, the coil pack that should come up on the Tech2 as random multiple misfire.

  6. #6
    Status
    Offline
    michty_me's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeah I was just wondering if anyone had seem similar with there GSi's. The mechanic at the local garage said he would stick it on the machines if it still wasnt running right once the gasket had been changed. It is running sooo much better now that it has been changed mind you and once vauxhall done there "field remedy" i have no idling issues. Its just this stutter around the 4000rpm mark. Will get it investigated as soon as I have more £££'s. Will go change the plugs etc first.
    Love the forums btw!

  7. #7
    Status
    Offline
    astraturbo1987's Avatar
    AOC Fanatic
    Join Date
    Mar 2007
    Posts
    457
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had the exact same problem with my mates gsi, and we tryed everything. it turned out to be the spark plugs, couldnt beleave it myself but it is perfect now. hope this helps!!

  8. #8
    Status
    Offline
    michty_me's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I was going to change the plugs and leads etc before I thought about putting it back in the garage. Hopefully that will help. Any recommendations for the GSi? any specific brands or is it a personal choice?

  9. #9
    Status
    Offline
    damosmokie's Avatar
    AOC Fanatic
    Join Date
    Apr 2007
    Posts
    300
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have a zafira gsi and have had similar problems i have just changed my spark plugs and it feels great now. I changed my plugs to NGK BKR6EIX they are iridium and run cooler so perform better. Give them a try you should get them for about £22 from a your local motor factor's. Hope that helps.

  10. #10
    Status
    Offline
    michty_me's Avatar
    AOC Regular
    Join Date
    Oct 2007
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Great thanks for your help guys. Will keep you posted on what happens.

Page 1 of 2 12 LastLast

Similar Threads

  1. Astra 1.9 sri 150 issue
    By joeno1 in forum Diesel Engines inc. Transmissions
    Replies: 3
    Last Post: 21-08-2014, 20:09
  2. Replies: 0
    Last Post: 07-03-2014, 15:18
  3. hid kit issue astra mk5
    By mellor18 in forum Electrical
    Replies: 0
    Last Post: 17-06-2012, 22:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •