Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Plz Plz Plz Help Me Engine Management Problems.

  
  1. #1
    Status
    Offline
    wayno2782's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Plz Plz Plz Help Me Engine Management Problems.

    Hi people im at my witts end i have a mk4 1.8 16v astra sport.I have had trouble with the car holding back on acceleration and the engine management light staying on.For example when i first get in the car there is no engine management light on and the car drives absolutely sweet then after about 5-10 mins guess what the engine management light comes on and it holds back and jerks about.And when i come to a junction and have to stop the revs sit at about 500 and the rev counter needle tends to go up and down slightly.I have bypassed the computer and it was telling me that there was a problem with the crank sensor which was replaced also the lambda sensor which was also replaced and the erg valve which was also replaced and still the light is staying on and its reading the same faults but these are all new parts that have been put on. Im wondering whether the engine management light needs clearing cause when its not on it drives super or should this go out automatically when the errors are fixed.Any help would be greatly appreciated thank you

  2. #2
    Status
    Offline
    Tlee's Avatar
    AOC Fanatic
    Join Date
    Dec 2006
    Posts
    985
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It seems like everyone is having this problem at the moment (including me), however I'm not getting any idling issues.

    I'm yet to attempt to fix anything yet due to lack of money but tomorrow I'm taking a look at the engine.

    Try changing the coilpack, or borrowing one from the same engine if you can, check the spark plugs and gaskets around the engine as oil may be leaking into one of the cylinders which could cause a misfire. Try cleaning the throttle body with carb cleaner that should help your idling issues. I dont think the X18XE1 has a Idle Control Valve, if someone could clarify this please do.

    List of things I've read that have solved this problem:

    New coilpack
    New EGR valve
    Cleaning of throttle body
    New AFM
    New CAT

    This thread here sheds a lot more light on the issue:

    http://www.cavweb-forums.co.uk/showthread.php?t=63293

    Astra MK4s are prone to gunking up the throttle body with oil vapours which when cooled goes hard. Faults of cutting out, lumpy idling and kangooring when driving can be attributed to a manked up throttle body and if not checked first a garage could rip you off big time as It can seem like an electrical fault (Plugs, leads, EGR, Air Flow meter)
    Its a 10 min job for yourself to check as all you need to remove is jubilee clip that secures the air flow pipe (the one that come from your airbox) to the throttle body and look inside. Mk4s for some reason can use a shit load of oil with no smoke and it will pass its emissions fine. If you have a mk4 thats a few years old (like mine is) and have any sort of engine running problems i would check the throttle body before you do anything as when mine was running really badly the throttle body was absolutely caked in hard oil. Once I had removed the throttle body (mine was far to caked to clean on the car so see your manual if you intend to clean off the car) and totally cleaned out the TB it ran like a dream and only cost the price for a tin of cleaner spray
    Astra is coming back..bigger badder and better
    ..or is it? Thinking of buying a coupe

  3. #3
    Status
    Offline
    tuyul_kecil's Avatar
    AOC Fanatic
    Join Date
    Sep 2006
    Posts
    565
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yup ive got the same problem aswell pls help and sometimes when cold the sound of the car is like going up and n down note like a shotgun shooting out from the exhaust

  4. #4
    Status
    Offline
    Tlee's Avatar
    AOC Fanatic
    Join Date
    Dec 2006
    Posts
    985
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Maybe you have a blocked exhaust tuyul
    Astra is coming back..bigger badder and better
    ..or is it? Thinking of buying a coupe

  5. #5
    Status
    Offline
    Cunny's Avatar
    AOC Fanatic
    Join Date
    Aug 2007
    Posts
    355
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    have you tried anythin like cleanin the spark plugs? i had a similar problem with my car not too long back.
    Sometimes I Wonder...Why do I live in this region

  6. #6
    Status
    Offline
    wayno2782's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy astra mk4 1.8 16v sport

    Tried new coilpack and it made no difference and i dont think its the gasket as not to long ago i had to replace a burnt out valve which was making my car misfire "like a shotgun sound" and shake the car very badly but i had that done and obviously they had to take the head of which meant replacing the gasket.Also ive changed the plugs to brand new ones! and still the same.

    what is the AFM and do u mean the cat which is in the exhaust

  7. #7
    Status
    Offline
    tuyul_kecil's Avatar
    AOC Fanatic
    Join Date
    Sep 2006
    Posts
    565
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    oh i think its because i told my exhaust guy to weld the silencer in my bazooka back box is dat y ? coz my i find no blue smoke or anything and i replace my broken afm aswell , also when i ran my car about 5 - 15mins today the eml came on and when i hold the rev to 3000rpm and i can hear the exhaust like misfiring so wat could these be ? is it my coil pack ?

  8. #8
    Status
    Offline
    tuyul_kecil's Avatar
    AOC Fanatic
    Join Date
    Sep 2006
    Posts
    565
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    what is the sign of broken valve if i want to check if mine is broken ? i dont think my system is blocked because i change my broken cat to a metal core one so i dont think its my systme but im thinking its my silencer that wats give it a bazooka shooting note sometimes

  9. #9
    Status
    Offline
    wayno2782's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    7
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    well when my exhaust was misfireing it turnt out it was only running on 3 cylinders because one of my valves had a chunk missing out of it im not saying this is your problem but its the same symptoms it could just be for u either needing some new spark plugs or a new coil pack i would defo try them first

  10. #10
    Status
    Offline
    tuyul_kecil's Avatar
    AOC Fanatic
    Join Date
    Sep 2006
    Posts
    565
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    change my plugs and not the coilpak ill try coilpak ty ,cos sumtimes my car runs fine 4 1 trip until i start up the car for the next trip then the eml light up and its juddering and kangarooing soo bad thats when i heard the exhaust like shooting sumthing

Page 1 of 2 12 LastLast

Similar Threads

  1. More Engine Management problems
    By Roylewaa in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 15
    Last Post: 30-11-2011, 15:12
  2. engine management problems
    By Hoggeh in forum Electrical
    Replies: 3
    Last Post: 10-03-2004, 10:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •