Results 1 to 9 of 9

Thread: 2.2 airbox problems!!!

  
  1. #1
    Status
    Offline
    reddevilastra's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    2.2 airbox problems!!!

    fitted the 2.2 airbox to Z20let SRi Turbo yesterday, everything went well extended the wires to AFM one at a time etc etc, then started her up and my manifold light stays on also my traction control light stays, so i dont have traction control anymore .
    has this happened to anyone else before or is my car just being stupid? and will it do damage to my engine if i still drive it?

    Thanks chris.

  2. #2
    Status
    Offline
    kev007's Avatar
    Cumbrian RO
    Join Date
    Jul 2005
    Posts
    2,061
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    check your wires.... make sure they are not touching and are the right way round.... sounds daft but i had one wire touching and my managment light and tc came on. also make sure your afm is right way round, aroow should point towards turbo... other then that get it on a dianogic machine...

    kev
    Where are the Cumbrian Members??
    Anyone Seen Them!

    Drives a Fiat Bravo 165 sport....

  3. #3
    Status
    Offline
    K3FUS's Avatar
    AOC Obsessed
    Join Date
    Nov 2004
    Posts
    5,752
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The lights may stay on until you drive the car a short distance and the ABS and TC reset themselves.

    Short distance = yards not miles
    Tell me what you've done, not what you're going to!

  4. #4
    Status
    Offline
    kev007's Avatar
    Cumbrian RO
    Join Date
    Jul 2005
    Posts
    2,061
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    try disconneting the battery for half an hour...
    Where are the Cumbrian Members??
    Anyone Seen Them!

    Drives a Fiat Bravo 165 sport....

  5. #5
    Status
    Offline
    reddevilastra's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks guys, will have another look to see if i can sort the problem..
    Thanks again chris.

  6. #6
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Also make sure you have the AFM on the right way round
    The truth is always the truth even if you haven't realised it yet...

  7. #7
    Status
    Offline
    reddevilastra's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yup fixed the problem....to my embarrassment i originally put the AFM round the wrong way ..its fixed now

    chris.

  8. #8
    Status
    Offline
    Madmonkee's Avatar
    AOC Fanatic
    Join Date
    Sep 2004
    Posts
    654
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    lol ^^ easy enough todo
    Aerospace NDT LvlII Technician En4179/Nas410.
    Certified, qualified Crack tester :P

  9. #9
    Status
    Offline
    reddevilastra's Avatar
    AOC Newbie
    Join Date
    Sep 2007
    Posts
    49
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    lol lol yea suppose so but the arrow on the AFM gives you a clue ....oh yea every things all good now.

    Chris.

Similar Threads

  1. 2.2 airbox conversion problems
    By t80 krs in forum Turbo Petrol Engines inc. Transmissions
    Replies: 7
    Last Post: 13-04-2010, 22:21
  2. 2.2 airbox problems
    By seanGsi in forum Turbo Petrol Engines inc. Transmissions
    Replies: 9
    Last Post: 19-05-2008, 22:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •