Results 1 to 6 of 6

Thread: Advice on Fuel Trims

  
  1. #1
    Status
    Offline
    MrCoupe's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Advice on Fuel Trims

    Bit of background - I will keep it as concise as possible.

    Car was running like poo, stuttering and hesitatating at half throttle, not really boosting and when i did was 'surgy' (off/on/off/on/off).

    Had a few bits of advice from the guys on here, one of which was change the plugs for iridium.. which i did.

    Not really hesitating as much now but still not pulling through the rev range like it was before.. better, but still pretty poor!!.. so... I borrowed an ODB2 cable and got myself some diagnotics software to try and see what was going on.

    I am currently looking at the short term fuel trim (will also look at long term after). Bank1 is hovering around 0, sometimes a few % above, sometimes a few % below... as expected (even under 100% load)

    HOWEVER.. Bank 3 is showing a pretty consistant value of -40% ie.. rich as hell!!

    My questions are..

    1. Is this -40% normal (i'm expecting not)
    2. If not, any ideas what to look at... and ....
    3. What the hell is the difference between bank 1 and bank 3.. I have no idea.

    This issue is doing my head in so appreciate any advice you can offer.

    I have a full dataset off the key sensors from a run i did today if anyone knows anything about this sort of thing and fancies taking a look at it...

    Thanks in advance
    Astra Coupe Turbo [242bhp / 270ft/lb]
    ..... Running like an asthmatic ant with heavy shopping as the moment

  2. #2
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Possibly an injector breaking down.

    Try swapping injectors around on the rail.

  3. #3
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have an ODB2 kit too. What exactly are the "bank"s?

    Lack off boost in half throttle conditions usually would be down to actuator adjustment.

    Also, my software does not show boost - does yours?, and if so, what software are you using?
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  4. #4
    Status
    Offline
    MrCoupe's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi Mike, i am using PCMSCAN.. it wasnt cheap but it does seem pretty good! The issue i have is understanding quite what i'm seeing lol

    What are your readings on Bank 3? I cant find any description online about what bank 1 and bank 3 actually are.. I dont have a bank 2 or 4 so i assume its not cylinders... confused

    I have a script for boost, but because Barometric Pressure and Manifold absolute pressure arent PID's supported by the ECU it doesnt work

    Have been able to prove that the O2 sensors are working ok so its not them at least.. Ignition advance seems to be pretty high compared with details i have found online but not sure if that's have anything to do with it.

    I'm clutching at straws really as i'm not totally sure what i need to be looking for or what the 'normal' values should be
    Astra Coupe Turbo [242bhp / 270ft/lb]
    ..... Running like an asthmatic ant with heavy shopping as the moment

  5. #5
    Status
    Offline
    Madmonkee's Avatar
    AOC Fanatic
    Join Date
    Sep 2004
    Posts
    654
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mine used to "surge" under acceleration, turned out to be the BCS (boost control solenoid) the plastic bit that sits ontop of the turbo, there is also another hding around the back of the engine.
    Aerospace NDT LvlII Technician En4179/Nas410.
    Certified, qualified Crack tester :P

  6. #6
    Status
    Offline
    MrCoupe's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    58
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Madmonkee View Post
    mine used to "surge" under acceleration, turned out to be the BCS (boost control solenoid) the plastic bit that sits ontop of the turbo, there is also another hiding around the back of the engine.
    This is definately on my 'list' of suspects. I intend to get a boost gauge in there and get the actuator set back right, then renew all the vacuum hoses as one at the back of the engine comes off sometimes (right down the very botom)

    Then BCS(s) if thats not the cause.

    Any idea why 2 BCS's.....?
    Astra Coupe Turbo [242bhp / 270ft/lb]
    ..... Running like an asthmatic ant with heavy shopping as the moment

Similar Threads

  1. Fuel trims
    By MeasorPaul in forum Turbo Petrol Engines inc. Transmissions
    Replies: 6
    Last Post: 21-11-2013, 01:03
  2. Fuel pump advice for a 2.0 DTi
    By mike0491 in forum Diesel Engines inc. Transmissions
    Replies: 4
    Last Post: 09-01-2013, 22:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •