Results 1 to 4 of 4

Thread: Changed speedo to white, now speed out?

  
  1. #1
    Status
    Offline
    midlifecrisis's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Cool Changed speedo to white, now speed out?

    I have just fitted a white dials unit I bought from ebay, it's great but one thing! The speed is reading about 12mph to high!
    How can I correct it?

    Thanks

  2. #2
    Status
    Offline
    rakesh's Avatar
    AOC Newbie
    Join Date
    Jul 2007
    Posts
    30
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Did the top speed on the new dial match your old one?

    Think you need to have the speedometer recalibrated. This company is offering the service:


    http://www.dashmasters.co.uk/page4.htm


    Probably worth trying Vauxhall first.

  3. #3
    Status
    Offline
    Coo's Avatar
    Banned
    Join Date
    May 2003
    Posts
    25,105
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds like you have not bought the same 'scale' of dial....
    As Rakesh says, you should have bought ones with the same top speed.

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Did u actually buy a replacement instrument cluster or just the white plastic faces?

    If its the first one then the only time this would usually happen is on brand new uncalibrated units or ones that have been taken apart and needles moved... If its just the faces then either whats already been suggested in that you have the wrong scale dials or that you didnt fit the needles in exactly the same position as before....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •