Results 1 to 9 of 9

Thread: Kenwood headache

  
  1. #1
    Status
    Offline
    RichCSRi's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Kenwood headache

    Right, going a bit mad here - I've read all I can find on the forum about fitting my Kenwood HU (http://www.justkenwood.co.uk/stock01/kdcw6031.asp) to use the steering controls and display but can't seem to plug everything in. I am using the PC99-X06-DIS connectors but cannot find:

    1 - where to plug the male mini-din type plug that comes from the dash. I have plugged the mini-din from the HU into the mini-din from the new connector lead.

    2 - where to connect the connector block from the patch lead that only has 3 pins in it.

    My HU was originally installed by the place I bought it from but only set up to use the steering controls. I have since bought the recommended wiring but getting nowhere with it. It currently has two blue wires spliced together and (i think) a loose yellow wire

    Anyone??

  2. #2
    Status
    Offline
    wywywywy's Avatar
    AOC Obsessed
    Join Date
    Sep 2005
    Posts
    1,478
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    First of all, make sure you have the correct unit...

    Quote Originally Posted by RichCSRi View Post
    1 - where to plug the male mini-din type plug that comes from the dash. I have plugged the mini-din from the HU into the mini-din from the new connector lead.
    There shouldn't be a mini-din plug from the dash. There is one from the headunit, one from the interface, you just need to connect them together.

    What I am guess is... may be you have not removed the old steering wheel control interface? Your NEW interface is for both MFD and steering wheel control, so you can discard your old interface.

    Quote Originally Posted by RichCSRi View Post
    2 - where to connect the connector block from the patch lead that only has 3 pins in it.
    The Astra connector has three blocks... one for speakers, one for power + steering wheel control, one for MFD. So I am guessing the one you are talking about should go to MFD block.

    Quote Originally Posted by RichCSRi View Post
    My HU was originally installed by the place I bought it from but only set up to use the steering controls. I have since bought the recommended wiring but getting nowhere with it. It currently has two blue wires spliced together and (i think) a loose yellow wire
    Make sure the old interface installed by that place is removed first... The yellow wire is probably the tele-mute wire, which is not needed unless you have a mobile phone car kit. If no wiring has been changed, the blue wires are probably antenna amp wires.

    But make sure you have the correct interface first because as far as I know the interface should come in two parts!!

    Would be much easier if you can take a pic mate!
    Astra Coupe Turbo Project Log KW var2, BK299, Apexi, HID, Angel, Leather Cobra, Phoenix Gold, GT/R2, Fluted, DV26D, Pre/Sports/Catback, CarPC, B&M, VXR Turbo, Tarox-10, Phase 3! Car is for sale!

  3. #3
    Status
    Offline
    RichCSRi's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Cheers, you were right - the old interface was still in place.

    I have put the new one in it's place (bit tight at the back now!) and all worked perfectly, however noticed this morning that after the ignition is turned off all the presets go! What do I need to check? Has me cramming the unit back in dislodged something?

  4. #4
    Status
    Offline
    RichCSRi's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ignore that - just done a search and found I need to swap the red and yellow wires round on the iso block due to vaux being odd

  5. #5
    Status
    Offline
    wywywywy's Avatar
    AOC Obsessed
    Join Date
    Sep 2005
    Posts
    1,478
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ah so sounds like everything is working now
    Astra Coupe Turbo Project Log KW var2, BK299, Apexi, HID, Angel, Leather Cobra, Phoenix Gold, GT/R2, Fluted, DV26D, Pre/Sports/Catback, CarPC, B&M, VXR Turbo, Tarox-10, Phase 3! Car is for sale!

  6. #6
    Status
    Offline
    RichCSRi's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The power issue is sorted now - the Kenwood's own harness had connectors on the red and yellow wire ready to be swapped!

    Although only issue remaining is the steering controls - both skip and volume up/down work fine, but the arrow (previously playlist skip) now changes the source on the HU and the actual source button on the steering controls triggers 'ATT' on/off on the HU.

    Checked all connections - anyone else had this problem??

  7. #7
    Status
    Offline
    wywywywy's Avatar
    AOC Obsessed
    Join Date
    Sep 2005
    Posts
    1,478
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I think thats how it supposed to work?
    I sold my Kenwood about a year ago for a Pioneer, so can't remember much now.
    Astra Coupe Turbo Project Log KW var2, BK299, Apexi, HID, Angel, Leather Cobra, Phoenix Gold, GT/R2, Fluted, DV26D, Pre/Sports/Catback, CarPC, B&M, VXR Turbo, Tarox-10, Phase 3! Car is for sale!

  8. #8
    Status
    Offline
    RichCSRi's Avatar
    AOC Newbie
    Join Date
    Aug 2006
    Posts
    20
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Really? The controls-only lead that I replaced made the source button (circle) work the same as the source button on the HU. At the moment it just (almost) mutes the sound.

    Cheers for your replies so far btw

  9. #9
    Status
    Offline
    wywywywy's Avatar
    AOC Obsessed
    Join Date
    Sep 2005
    Posts
    1,478
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yea thats attenuation.
    By the way this is also how my Pioneer adaptor works.
    Astra Coupe Turbo Project Log KW var2, BK299, Apexi, HID, Angel, Leather Cobra, Phoenix Gold, GT/R2, Fluted, DV26D, Pre/Sports/Catback, CarPC, B&M, VXR Turbo, Tarox-10, Phase 3! Car is for sale!

Similar Threads

  1. it gave me a headache, but i've done it!
    By rusty in forum Astra Discussion & Chat
    Replies: 40
    Last Post: 19-05-2004, 23:31
  2. Headache
    By nuttynovas in forum Chit Chat and a Warm Welcome!
    Replies: 1
    Last Post: 17-08-2003, 18:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •