Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: TC Light Coming on, with EMC.

  
  1. #1
    Status
    Offline
    Zafauto's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    TC Light Coming on, with EMC.

    This first happened back in Jan 2005. Just drove my Zaf 1.8 auto 100 yards up the road when there was a sudden deceleration and reduction in power. Both EMC and TC lights were on. A restart cleared the TC light and the car drove normaly. The EMC light took a couple of days to clear.

    Took the car to the main dealer who did a Tech 2 which found no fault codes in Traction Control/ABS system. Found that the ECU software was out of date, so updated it and charged me £60.

    In the 2.5 years since then fault has reappeared 2 or 3 times and cleared, however yesterday the wife drove to a town 50 miles away with no problems but on the return trip fault reappeared 3 times . Each time the TC light cleared after a restart, but the EMC light is still on when i drove the car this morning with no TC problem. I guess EMC will clear in the next day or two as previous.

    Am i right in thinking that whatever ECU corrective action is taking place when it thinks there is a TC problem is causing the EMC light to come on? Does this light usually latch on then clear after so many starts?
    Anyone Know where the cause of the TC light problem is likely to be, as I am loath to take it to the main dealer again just to throw money away on further Tech 2 checks?

  2. #2
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Welcome to the site.

    Possible problems are a duff air flow meter or a dirty EGR valve, you should be able to remove the exhaust gas recirc valve and clean it yourself.
    Not sure TBH, but may be worth a go.

    Warning lights can be a bit hit or miss really, sometimes a faulty AFM will not show a fault light at all and, I have heard, a duff unit will throw up a TC/ABS warning light.

  3. #3
    Status
    Offline
    Zafauto's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks Montyfox for the welcome and reply. Had a word with my local garage today and they suspect a wheel sensor is causing TC light and loss of power is Limp Mode. When i asked what the connection could be with the Emissions light they said that if it was the warning symbol that looked like an engine then it was the ECU fault light?

    According to my handbook the engine symbol on petrol cars is emissions, and the car with a spanner through it is electrical fault light, and only on diesels is the engine symbol electrical faults. Maybe mine`s wired up wrong!

    Anyhow they are putting a computer on it tomorrow and all might become clear. Needless to say that after another occurance yesterday, worked as advertised today.

  4. #4
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Faulty hub sensor could be possible for your symptoms. Jeez, cars are pretty complicated these days

    The warning lights are a bit confusing but as I said before, the lights and faults don't correspond, if they light up at all.

    For example, my GSi was running a bit poor for a while so I carefully cleaned the AFM and things improved a fair bit, but I still wasn't 100% happy with it so i changed it for a new one at the weekend and what a difference , so much better now.
    No fault light was showing for this at all!!!

  5. #5
    Status
    Offline
    Zafauto's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Todays check for stored fault codes showed misfire on cylinder four. Garage recon it`s the coil pack. Cleared fault code, but fault reappeared this afternoon. another check of stored codes showed misfire on 4 again. Looks like i need a new coil pack then!

  6. #6
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Quote Originally Posted by Zafauto View Post
    Todays check for stored fault codes showed misfire on cylinder four. Garage recon it`s the coil pack. Cleared fault code, but fault reappeared this afternoon. another check of stored codes showed misfire on 4 again. Looks like i need a new coil pack then!
    Its all going a bit epic!

    May be worth trying to clean/checking your spark plugs before splashing out on a new coilpack.

    Looking foward to your next exciting installment LOL.

    good luck!

  7. #7
    Status
    Offline
    Zafauto's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Here is the next exciting installment While waiting for a new coil pack to arrive, from the Vauxhall Spares Centre, on eBay, as local garage couldn`t get near their price of £55 + £6.50 next day delivery. However, this will probably be monday up here in the North of Scotland! Emissions and Traction control light have been replaced by the car with a spanner through it, electronic problem light.

    This is the light I would have expected to see with an intermittent misfire problem and not the TC light. Strangely with this light on the car appears to be running normally

  8. #8
    Status
    Offline
    Zafauto's Avatar
    AOC Newbie
    Join Date
    Jun 2007
    Posts
    12
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    New coil pack arrived today and I fitted it immediately. Got the local garage to plug in and remove the car/spanner warning light which was still showing and the stored mis-fire on number 4 cyl code then off for a test drive. Passed with flying colours, no mis-fires and no warning lights.
    Fingers crossed, will give it a week then update this post .

  9. #9
    Status
    Offline
    montyfox's Avatar
    AOC Obsessed
    Join Date
    Apr 2006
    Posts
    7,434
    Mentioned in
    1 Post(s)
    Quoted
    1 Post(s)
    Cool as beans, hopefully this is now sorted

  10. #10
    Status
    Offline
    Ton3h's Avatar
    AOC Newbie
    Join Date
    May 2007
    Posts
    23
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    damn those coil packs!

    Hope it sorts it for you, like it did me

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 9
    Last Post: 25-03-2010, 19:18
  2. abs light and tc light coming on, speedo not working!?!
    By drfeelgood in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 10-04-2008, 23:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •