Results 1 to 3 of 3

Thread: Temperature dial has stopped working!

  
  1. #1
    Status
    Offline
    Dannywrc's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,062
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Temperature dial has stopped working!

    Iv been having problems with my car for the past few weeks.

    Its been running lumpy and spluttering when im cruising. I took it to a garage and they said it was the air/water temp sensor and they replaced it.

    the car was fine for a couple of weeks but it started doing the same again.

    Today the temp dial stopped working but now my car runs fine.

    Any ideas what the problem could be and how to fix it?

    please help,

    cheers

  2. #2
    Status
    Offline
    RobW's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    3,411
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    What car and what engine?!

  3. #3
    Status
    Offline
    Dannywrc's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,062
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sorry mate that would help.

    Its a 1.6 16v eco mk3

Similar Threads

  1. Please help. Temperature dial on MK4 astra not working.
    By Thermo_Monkey in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 10
    Last Post: 22-12-2012, 18:21
  2. MFD stopped working
    By Robc in forum Electrical
    Replies: 2
    Last Post: 20-02-2007, 08:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •