Results 1 to 4 of 4

Thread: Intermittent rough running Zaffy. Opinions?

  
  1. #1
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+

    Intermittent rough running Zaffy. Opinions?

    Car : Zaffy Z16XE

    Symptoms : Emissions light pops on from time to time, rough lumpy idling, no power. Eventually clears itself and light goes back out after a few runs.

    Error codes : P0300, P0304 (Misfires detected)

    So far cleaned throttle body, replaced plugs, EGR, & O2 sensor.

    Diagnosis : I think me coil pack is about to pop it's clogs.

    I know I've probably answered my own question, just curious as to what you all think?
    Actively proving that post counts mean jack sh*t since 1971

  2. #2
    Status
    Offline
    jam's Avatar
    AOC Gold Member
    Join Date
    Apr 2005
    Location
    Tamworth, Staffordshire
    Posts
    11,695
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Follow jam On Twitter
    Sounds like the problem to me! Where abouts are you? We don't have any members close to the moon but if your on earth then we may have a member who you can swap the coil pack over with just to make sure.

    jam
    Its a jam thing

    Haec credam a deo pio, a deo justo, a deo scito?



  3. #3
    Status
    Offline
    ewokszaf16v's Avatar
    AOC Regular
    Join Date
    Jun 2006
    Posts
    239
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had this on my old engine , turned out to be the cat !! costo much dosh but fixed the problem

    hope this helps

    ps , dnt buy a cat from vx , go to an after market one as it makes the engine rev better , i had a full system from the downpipe back done by longlife and its made it a lot more fun to drive !! had the lot done for 400 quid cat inc
    1.6 16v zaffy getting there slowly ...............

  4. #4
    Status
    Offline
    AndyH's Avatar
    Bit busy... be back soon!
    Join Date
    Jul 1971
    Drives
    Astra Coupe 2.2
    Posts
    300,024,286
    Mentioned in
    133 Post(s)
    Quoted
    30 Post(s)
    Follow AndyH On Twitter Add AndyH on Facebook Add AndyH on Google+
    Nice idea Jam, I'm actually in Northampton. Only trouble is because of it's intermittent nature, it's trying to catch it on an "off-day" as it were. It's running ok at the mo, has been for about a week...

    Think I might try the coil pack route first - can get them on eBay for £55 all in. Considering I'm driving to Scotland on Saturday, it might be prudent!!
    Actively proving that post counts mean jack sh*t since 1971

Similar Threads

  1. Running a bit rough
    By spudmorley in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 28-10-2013, 15:48
  2. Running Rough
    By Milki in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 19-12-2007, 14:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •