Results 1 to 7 of 7

Thread: Abs and tc light come on when driving

  
  1. #1
    Status
    Offline
    *dannyboi*'s Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    724
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Abs and tc light come on when driving

    i have noticed recently that the abs and tc lights come on while am driving. And i do not have abs or tc when these lights are apperd. I have to turn the car off and wait for a bit the start it up and its fine. What could this be?

    My car is a 1998 2ltr astra sri

    cheers
    Astra GSI Arden Blue
    518bhp 432 ftlb torque

  2. #2
    Status
    Offline
    RobW's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    3,411
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Most likely the wheel sensors which are part of the hub. They are about £80 each from autovaux but try one at a time starting with the passenger side.

  3. #3
    Status
    Offline
    sam_p2000's Avatar
    AOC Regular
    Join Date
    Jan 2007
    Posts
    171
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    this happened to my 2.0 1999 sri and ended up being one of the speed sensors as mentioned above. To start try removing the plugs (white plug just behind each front disc accessible with the wheels off) and spraying them with WD40 to drive out any moisture.
    X20XEV Gsi Now sold but now have a Corsa GSi C20XE

  4. #4
    Status
    Offline
    Ruperts Trooper's Avatar
    AOC Obsessed
    Join Date
    Dec 2005
    Posts
    1,471
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If you get the diagnostics read - paper clip / OBD2 / Tech2 - it'll identify which hub sensor has failed.
    Maintains:- Vectra Design 1.9CDTi
    Drives :- Hyundai Santa Fe


  5. #5
    Status
    Offline
    MC1's Avatar
    AOC Fanatic
    Join Date
    Jan 2006
    Posts
    420
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    interesting as a mate of mine has the same problem with there mk4 hatch
    astra coupe now sold and driving fiesta ST now sold and awaiting mk3 astra to arrive

  6. #6
    Status
    Offline
    GoldenCoupe's Avatar
    AOC Newbie
    Join Date
    Feb 2006
    Posts
    19
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It will most probably be the sensor having moisture in it. Mine done exactly the same, however after i stoped using the presure washer in the wheel arch it fixed itsself. Not had the problem since. Also as mentioned above I had a diagnostics report that confirmed what side.

  7. #7
    Status
    Offline
    Buzz's Avatar
    AOC Regular
    Join Date
    Feb 2006
    Posts
    168
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hey guys had exactly the same problem. To fix this i took appart the white connectors at each wheel hub and sprayed disk brake cleaner in as this evaporates and leaves no residue, let them air for half an hour whilst i had a coffee and reconnected them back up and jobs a good un.

Similar Threads

  1. my esp light stays on while driving
    By checkez in forum Astra Discussion & Chat
    Replies: 1
    Last Post: 08-10-2012, 06:22
  2. Traction & Abs Light Comes On When Driving
    By ukez in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 14
    Last Post: 19-05-2007, 00:32

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •