Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: z20let turbo problems after fitting precat decat

  
  1. #1
    Status
    Offline
    slimbo1982's Avatar
    AOC Regular
    Join Date
    Apr 2006
    Posts
    83
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Exclamation z20let turbo problems after fitting precat decat

    well it all started when i fitted my precat decat all went on fine car was sweet ,bit of an improvement noticed to but then a few weeks after fitting it the car starts smoking (white, blue) and i was told it was the turbo had blown which i found hard to believe as i hadnt given it much abuse and always warmed it up and cooled it down and has only done 36000 miles roughly.
    so any way i managed to buy a second hand turbo from a friend which had only covered 20000 miles and was in good conditon and i know it was looked after so i fitted that to my car and hey presto everything back to normal car was boosting up no smoke anymore wicked problem solved i thought... its been about a month since fitting the turbo and guess what it has started to smoke again which is not right i havent been abusing it at all and has just gone aswell, so i am led to believe it has something to do with the precat replacment as i had no problems before fitting this.

    i was reading on the forum sombody else had same problem something to do with loss of back pressure making the turbo spin faster or sumin i dont know?

    so if any body has any ideas why this is happening or if it has happened to you and how you resolved it that would be great as i have a brand new vxr turbo sitting here waiting to be fitted but i dont want the same thing to happen to this, i think i might put the std precat back on?

  2. #2
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    i have vxr turbo and a precat decat and have had no probs 2 date and so have others.
    cant see how decatting the precat would cause turbo probs

  3. #3
    Status
    Offline
    slimbo1982's Avatar
    AOC Regular
    Join Date
    Apr 2006
    Posts
    83
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    im not to sure either but it was fine until fitting the decat? and i cant see how two turbos can blow within two months from fitting it.

    i was just reading on the zlet website that you need to put a gasket between the turbo and the precat but when i removed the std one it never had a gasket and i never fitted one maybe this has somthing to do with it air leaking from the join???

  4. #4
    Status
    Offline
    norm29's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,660
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the gasket is a very rare find just bad luck id say matey, the turbo was used you fitted so could have been on its way out
    Car broken- A3 170 quattro s-line

  5. #5
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    i dont have a gasket on mine,as a seal can be gotten without a gasket as it says on the fitting instructions on zlet. i aint paying the silly price that vaux want for a shitty bit of metal,lol

  6. #6
    Status
    Offline
    slimbo1982's Avatar
    AOC Regular
    Join Date
    Apr 2006
    Posts
    83
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    so what do you think about fitting the vxr turbo do you think ill be ok with it ? just cost me a bomb dont wanna kill that to cheers

  7. #7
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    no guarentees in this world m8. but many others have done this mod with np's. like i said i have no gasket and works like a dream

  8. #8
    Status
    Offline
    Enkidu's Avatar
    AOC Obsessed
    Join Date
    Feb 2006
    Posts
    2,716
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ideally you need to send the turbo off to technicians that can tell you why it failed. For instance it could be starved of oil...

    Fitting the pre cat will not damage the turbo. I fitted the full milltek without any problems and have since had a remap done too.
    Arden Astra GSI - Phase 3.5

    EDS Phase 3.5 288 BHP 340 FT/LB

    Inlet cam and Dbilas manifold.

  9. #9
    Status
    Offline
    G-UNIT's Avatar
    AOC Obsessed
    Join Date
    Jul 2006
    Posts
    1,274
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i have been told that if you get this done you may need the car remapped?

  10. #10
    Status
    Offline
    K3FUS's Avatar
    AOC Obsessed
    Join Date
    Nov 2004
    Posts
    5,752
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I would get your oil feed checked as there's something not right.
    Tell me what you've done, not what you're going to!

Page 1 of 2 12 LastLast

Similar Threads

  1. help fitting decat precat
    By Gleebe De Turbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 25
    Last Post: 21-05-2014, 18:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •