Results 1 to 8 of 8

Thread: Exhaust Emissions light on but not flashing.

  
  1. #1
    Status
    Offline
    Kluivert's Avatar
    AOC Regular
    Join Date
    Jul 2005
    Posts
    285
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Exhaust Emissions light on but not flashing.

    2003 1.2 16v Opel Astra 53k miles.

    The light came on with a loss on power.

    Anyone ever encounter this problem before i book it into the garage for the girlfriend. Just to give me the heads up before approaching the garage.

    Not flashing (yet) so the cat conventor is ok for the time being.
    1.4 1999 Opel Astra 140,000 miles.
    Roll on 200,000 miles!

  2. #2
    Status
    Offline
    tuyul_kecil's Avatar
    AOC Fanatic
    Join Date
    Sep 2006
    Posts
    565
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    get it check mate tech 2 coz it can be any problems in the engine. or check cable connections in the engine bay

  3. #3
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Could be a number of things but ideally the only way of confirming is to have it hooked up to a Diagnostic machine. If u dont fancy paying main dealer Opel prices for a Tech2 hook-up then u could try a local independent with the same facilities that may charge approx half if not less what the dealer does.

    Sorry its not really the answer u wanted to hear but that light covers a variety of different components and an online diagnosis really isnt an option. We can quite easily give u a list of possible failed components but it'd be a case of changing one part at a time until u reach the culprit - whereas a quick trip to a specialist and a few mins on a diagnostic hook up should tell u straight away what is at fault.

    As mentioned above - u could check the connections to the EGR valve if fitted as this can sometimes cause EML to come on.

    Good luck and keep us posted.

  4. #4
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My guess is the coil pack, but like what's already been said, there's a variety of different components.

  5. #5
    Status
    Offline
    jonuk7's Avatar
    AOC Fanatic
    Join Date
    Jan 2007
    Posts
    425
    Mentioned in
    0 Post(s)
    Quoted
    6 Post(s)
    mine just did the exact same thing and on its Tech 2 came back with the EGR Valve is fu***d. £30 Ebay brand new one on my doorstep within 48hrs, fitted and problem sorted.
    Astra G SXI, Tints, Remus centre, twin backbox, Autoclosure, Rainbow dash LED's, debadged. POWER!!!

  6. #6
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    EGR would be my initial suspicion followed closely by CP. But u really need it hooked up to the OBD to be sure.

  7. #7
    Status
    Offline
    Kluivert's Avatar
    AOC Regular
    Join Date
    Jul 2005
    Posts
    285
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks lads for the advice the car is booked in for a service so she will find out soon enough.

    The light hasnt come back on in a couple of days so hopefully it was nothin too bad.

    I would be disappoint if its the EGR value to be honest, the car only has 53k miles, funny enough the engine doesnt very bad, ticks over very loudly like an old sowing machine, I just put that down to the value that realises exhaust fumes. Cant think of the name straight off. Purge Value.
    1.4 1999 Opel Astra 140,000 miles.
    Roll on 200,000 miles!

  8. #8
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    EGR is common problem regardless of mileage -mines just gone as we speak and Im getting the tickin noise u describe - personally Id say its just the tappets - presume the noise goes away once the engine warms up?

    Anyway hope u get it sorted and keep us posted

Similar Threads

  1. 1.6 SXI flashing emissions light - HELP!!!!!
    By candice883 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 10
    Last Post: 12-08-2012, 21:00
  2. HELP, lost power, Emissions Warning Light Flashing
    By trancemaster in forum Astra Discussion & Chat
    Replies: 2
    Last Post: 24-03-2006, 21:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •