Results 1 to 9 of 9

Thread: Engine light on astra g gsi any ideas?

  
  1. #1
    Status
    Offline
    vauxtillidie's Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    690
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)

    Engine light on astra g gsi any ideas?

    After sitting in very slow moving traffic for an hour today the engine light came on (one with a car and spanner) and the boost dropped to around 4 psi.

    I limped home gently and turned ignition off and started engine again hoping the light would go off but it didnt however the boost has returned back to normal

    any ideas what could have gone wrong, the engine is standard apart from a regal powerpipe and baileys dump valve and has done 48k.

    i realise it will probably need to go on tech 2 just wondered if anyone had similar problem or knew what the cause mite be

    cheers

    Chris

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My initial suspicion would be the infamous AFM - if so, any1 u know have the same car so u could try theirs?

    then again I dont have a ZLET so I could be miles out...

    someone will be along soon to confirm hopefully.

  3. #3
    Status
    Offline
    Scottyboy's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,750
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Always suspect the AFM first imo - if you swap it over, it will still take a few miles of driving for the light to extinguish.

  4. #4
    Status
    Offline
    spanishfly's Avatar
    AOC Fanatic
    Join Date
    Jul 2003
    Posts
    418
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    as per www.vauxsport.co.uk

    AFM.

  5. #5
    Status
    Offline
    vauxtillidie's Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    690
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    well last night i decided to unplug the afm and plug it bak in whilst engine was running (dont ask me why!) but the light did go out after a few miles of driving!

    do you think its worth getting a new afm anyway as its twice ive had this problem so maybe it is on its way out?

  6. #6
    Status
    Offline
    Scottyboy's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,750
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You will not solve the problem with unplugging and pluuging back in the same part if it is that which is gone - unplugging whilst running might even compound your problems! It sounds like it is on it's way out anyway - so it will probably go again in a few days time.

    My advise is always the same with AFM's - buy a spare anyway and try it - if it isn't the problem, you will probably need it anyway in the future - if not then simply sell it on, there will always be people wanting one.

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As we've all said so far - pretty sure its the infamous AFM

    IMO all ZLET owners should have a spare AFM just in case.

    Vx charge £120+vat for a new unit (Part number: 9201425) but u can pick up exactly the same brand new unit for £80 delivered on ebay.

    Here's the link if ur interested: http://cgi.ebay.co.uk/Vauxhall-Air-F...QQcmdZViewItem

  8. #8
    Status
    Offline
    vauxtillidie's Avatar
    AOC Fanatic
    Join Date
    Jul 2006
    Posts
    690
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Cheers everyone, ill get one when i get payed. vaux want 108+vat (trade) and cheers for the link to ebay

  9. #9
    Status
    Offline
    Scottyboy's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,750
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    LMF and Courtenay also sell them for 99 quid iirc. Let us know if it solves the problem.

Similar Threads

  1. Replies: 5
    Last Post: 17-07-2010, 19:46
  2. Engine light comes on when doing about 70-80MPH - Any ideas please
    By blacksri-ry in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 27-03-2010, 12:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •