Results 1 to 9 of 9

Thread: "Engine" Light!?

  
  1. #1
    Status
    Offline
    GSI_Butch's Avatar
    AstraSport Member
    Join Date
    Apr 2004
    Posts
    2,681
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    "Engine" Light!?

    Hi,

    I just come bk from a bit of xmas shopping and on the way bk my Engine Light came on! Its NOT the one with the spanner thru it, its the light with the pic of just an engine! I wasnt booting it or thrashing the car as my babbi was in the bk and I couldnt go over 20mph due to the town traffic!

    Recently I had problems with the EngineSpanner light comin on and described it all in another thread. which is here >>> http://www.m1gst.com/vb/showthread.php?t=86587

    Has anyone got any ideas as to what the prob could be? and is it ok to drive it?


    Mods are: veccy pipe, deresticted box, courtenay filter, powerpipe and DV, FMIC, precat and straight thru exhaust system!
    GSi Turbo - CS2 - 253bhp / 275ft/lb Torque
    1/4 mile - 14.62secs @ 95.5mph

  2. #2
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Isn't it the Engine Electronics? Shouldn't be bad driving it, although it could lead to more problems.

    Mines on too, again. Also not running up to scratch either.

    Edit: Just realized this is posted in to C20LET, Z20LET, Z20LEL, Z20LEH bit, mines a Z16XE but shouldn't be much difference with regards to the light problem.

  3. #3
    Status
    Offline
    djexplosive's Avatar
    AOC Regular
    Join Date
    Sep 2006
    Posts
    129
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i know exactly what ur talking about m8,

    today again took mine to vaux they told me must be afm, as recently had 02 sensors changed, cost me a fortune!
    and the manager said last resort would be a ecu faulty, but that rarely happens, and it should be the afm needs replacing.

    i would check over yours m8, make sure it is fully working etc, tightened up etc, and if in doubt trry a change first,

    let me know how you get on as its puzzling me too!

    DJ

  4. #4
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    yep my AFM has gone as well,get the engine light and taction control light on, been on for few days. car cuts out now and again as well, idles erractically from cold too. new afm 2moz should sort

  5. #5
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by djexplosive
    the manager said last resort would be a ecu faulty, but that rarely happens
    It was my ECU when it first happened to me . Luckily, the car was still under warrantry

  6. #6
    Status
    Offline
    GSI_Butch's Avatar
    AstraSport Member
    Join Date
    Apr 2004
    Posts
    2,681
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Andy_pandy
    as well, idles erractically from cold too.
    Mine does that too mate, it revs constant about 1100rpm then after a few mins goes down to 800rpm!


    Quote Originally Posted by djexplosive
    i know exactly what ur talking about m8,

    today again took mine to vaux they told me must be afm, as recently had 02 sensors changed
    and the manager said last resort would be a ecu faulty, but that rarely happens, and it should be the afm needs replacing.

    i would check over yours m8, make sure it is fully working etc, tightened up etc, and if in doubt trry a change first,

    let me know how you get on as its puzzling me too!

    DJ
    I am going to Vxl today to go on Tech2! free luckily as i know the lad but they are all mongs up there and each techie says a different thing! Firstly last week my fault code was P0170 Fuel trim, the guy said it was prob Oxy sensor around the exhaust, b4 and after the cat!

    I am thinking about gettin a new afm and then gettin it remapped with CS2! that may sort the fuellin out!

    We'll see what happens at Vxl today! Its at 1130 so check after that!
    GSi Turbo - CS2 - 253bhp / 275ft/lb Torque
    1/4 mile - 14.62secs @ 95.5mph

  7. #7
    Status
    Offline
    Gnasher's Avatar
    AOC Obsessed
    Join Date
    Oct 2005
    Posts
    1,897
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Whats the score Butch? Is the black beast buggered???
    2006 Astra VXR on 19's in Arden Blue
    ExhaustsUK Catback, Eibach Sportlines, DS Ultima, Roose hose kit, Forge recirculating dump valve, Full self modded SMD conversion

  8. #8
    Status
    Offline
    welsh-andy's Avatar
    AOC Obsessed
    Join Date
    Oct 2006
    Posts
    7,176
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    took mine in for warrenty purposes for the RAC.cause they wont pay for diagnostics, so spent £35 at vaux on a tech 2 test to tell me sumit i already know, P0100, MAF metre. grrr.
    least will be replaced monday free of charge,thank god for warrenties eh

  9. #9
    Status
    Offline
    GSI_Butch's Avatar
    AstraSport Member
    Join Date
    Apr 2004
    Posts
    2,681
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Right, sorry took so long replying but i took her to vxl and ...

    the engine light was due to a sensor in the fuel tank sayin that the tank was empty or has been running on low fuel!!! I alway keep at least an 1/8 of fuel in the tank so aint got a clue why this happened! So they replaced the part on warrenty, turns out i had this part replaced before about 2yr ago!

    Also had em check out my steering wheel as it was loose! i mean i could rock it with about 1/2inch movement! ... matey says "oh yeah its a common fault, we'll see if we can get it done on warrenty" .... to which i replied "NO you WILL get it done on warrenty!" ... in the end he did!
    GSi Turbo - CS2 - 253bhp / 275ft/lb Torque
    1/4 mile - 14.62secs @ 95.5mph

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •