Results 1 to 4 of 4

Thread: 1.7cdti starting problems

  
  1. #1
    Status
    Offline
    Gezawood's Avatar
    AOC Newbie
    Join Date
    Nov 2006
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy 1.7cdti starting problems

    Hi everyone, this is my first thread as I'm new to the web site.
    I have a problem with a 1.7 cdti on a 53 plate that won’t start MOST of the time hot or cold; it turns over ok and needs a shot of WD40 down the air intake to get it to go. The air and fuel filters have been changed and injector cleaner been run through it, I don't get any engine management warnings when the cars running.
    I’ve been told it’s the Mass Flow Meter/ air meter, but wouldn’t that also cause it to run very erratic?
    I'm new to Astra's and modern diesel engine the only experience of air meter problems I have encountered have been on an old Vectra type B petrol and this didn't stop it from starting, I could do with help here.
    Does anyone have any advice I would greatly appreciate it thanks

  2. #2
    Status
    Offline
    ZS's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    9,491
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If you keep on cranking, will it eventually fire? I'm talking sort of 10 seconds of cranking.

    As the 1.7CDTi is just a slight variation if the old 1.7DTi, it's inherited the dodgy glow plugs. If a good crank eventually gets it going, then it'll be the plugs.
    2007 Metro Blue 5 door Mk5 Elite 1.7CDTI
    6th Vauxhall (4th Astra) in 10 years...plus a couple of other sheds...

  3. #3
    Status
    Offline
    Gezawood's Avatar
    AOC Newbie
    Join Date
    Nov 2006
    Posts
    2
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hi, Yup, tried that it didn't work either, it just started to flatten the battery after a while, so I think the glow plugs are ok.

  4. #4
    Status
    Offline
    Windrew's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Location
    Golborne, Wigan, United Kingdom
    Posts
    4,637
    Mentioned in
    2 Post(s)
    Quoted
    5 Post(s)
    its not the fuel relay for the pump is it?
    ARDEN BLUE GSI

Similar Threads

  1. 1.7cdti Astra SRi not starting
    By belfast-SRi in forum Diesel Engines inc. Transmissions
    Replies: 1
    Last Post: 27-01-2012, 20:21
  2. Astra 1.7CDTI MK5 54 Plate Starting Problems (Like Stalling)
    By leehillyer in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 27-10-2009, 12:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •