Results 1 to 10 of 10

Thread: Corsa GSi problem

  
  1. #1
    Status
    Offline
    K70 RAF's Avatar
    AOC Fanatic
    Join Date
    Feb 2004
    Posts
    422
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Corsa GSi problem

    Right, my mate has just brought a corsa gsi and it is having trouble idling as it is sitting at 1500 revs. Also it is jurking and hesitating, but the engine management light is not coming on. Thought it might be the AFM or the idle speed control valve. Any ideas??

  2. #2
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    what year one dose he have a early or the late one ?

  3. #3
    Status
    Offline
    Tizy's Avatar
    AOC Regular
    Join Date
    Jul 2006
    Posts
    107
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had an "L" reg corsa gsi. It was only 3 years old at the time and i had the same trouble.

    Vauxhall fixed it for me for £600, but that was some years ago.

    They had to replace some bent valves on mine.

    My car was fine for about 5 or 6 month then the problem occured again !!!

    I had to pay another hefty bill again !!

    I seen something on "Watchdog" about the casing for the valves was to tight for the valves to move properly,

    On the way home from vauxhall i traded it in for a ford mondeo and got rid of it was a nice car though

    http://www.myastra.homestead.com/

  4. #4
    Status
    Offline
    Craig's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    17,804
    Mentioned in
    1 Post(s)
    Quoted
    0 Post(s)
    My mate has a GSI corse with a similar problem but IIRC it was some sort of electrical part that causes it

    i aint spoken to him in years so prob no chance of me finding out
    Ibiza FR CR TDI with 203 BHP

  5. #5
    Status
    Offline
    BYRON's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    6,649
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

  6. #6
    Status
    Offline
    Benskett's Avatar
    AOC Regular
    Join Date
    Oct 2006
    Posts
    173
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ICV maybe? Take it out give it a good clean and WD40 it.

  7. #7
    Status
    Offline
    sri-turbo-19's Avatar
    AOC Fanatic
    Join Date
    May 2006
    Posts
    900
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    crank shaft sensor.. sounds like what mine had!
    previous car - SRI Turbo
    new car - Focus RS

  8. #8
    Status
    Offline
    markja's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    1,890
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    idle control valve or coilpack

    having re read it defo idle control mate, my guess is its stuck in one place happened on my corsa when i had it, try geting some electrical cleaner from halfrauds itll be with the wd40, failing that i got a new one from vauxhall relativly cheap
    YOUR FRIENDLY WINDSCREEN MAN

  9. #9
    Status
    Offline
    K70 RAF's Avatar
    AOC Fanatic
    Join Date
    Feb 2004
    Posts
    422
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    cheers ppl its a m reg by the way

  10. #10
    Status
    Offline
    PhatNova!!!'s Avatar
    AOC Fanatic
    Join Date
    Oct 2005
    Posts
    380
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by K70 RAF
    Right, my mate has just brought a corsa gsi and it is having trouble idling as it is sitting at 1500 revs. Also it is jurking and hesitating, but the engine management light is not coming on. Thought it might be the AFM or the idle speed control valve. Any ideas??

    Mine did this wasnt a GSI but and S reg 1.2 thing was some engine sensor, but my EM light did come on ! maybe if it was doing it when kid sold it he might have been cheeky and taken bulb out of EM light !! i know a lad who did this with a focus ST170 cause he knew he couldnt sell it with light on !

Similar Threads

  1. corsa problem
    By AstraBoi2k8 in forum Car Chat (other marques/models)
    Replies: 0
    Last Post: 24-03-2011, 13:31
  2. problem with corsa 1.2 16v 99
    By fz911 in forum Car Chat (other marques/models)
    Replies: 3
    Last Post: 02-09-2008, 00:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •