Results 1 to 5 of 5

Thread: Part throtle response Z20LET Phase 2, 3

  
  1. #1
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Part throtle response Z20LET Phase 2, 3

    Hi all,

    I've had both Phase 2 and Phase 3 (EDS) on my car and I always experience silly boost when in part throttle. What happens is that when you press the accelerator it half way the butterfly is wide open but the internal recirc valve tries to recirc the charged air. But until that happens, you may experience for a few secconds high boost (1 bar) with no fuel at all (very lean) and with no respective power. Then the recirc finally opens and boost goes down to normal. This is very critical and unhealthy for the engine. I have an EGT and Halmeter gauge on the car and I can see exactly what happens at that time. For those 1 or 2 seconds, EGT goes sky high and mixture is very lean.

    Do you have the same proble? Is it a common issue with those remaps?

    It seems that EDS is missing an ECU map which has not been altered accordingly,

    Thanks a lot,

    P

  2. #2
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Any similar experiences? Anyone with Phase 3?

  3. #3
    Status
    Offline
    Neilc's Avatar
    AOC Obsessed
    Join Date
    Apr 2004
    Posts
    1,020
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could a faulty boost solenoid be the problem ??
    Insignia CDTI 160
    200bhp DTUK
    2007 Suzuki GSXR for the weekends

  4. #4
    Status
    Offline
    sxi boy's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    1,420
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    was it regal who did the map?...

  5. #5
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yeap, why? We have seen it in other Z20LETs as well..... weird

Similar Threads

  1. Part throtle response Z20LET Phase 2, 3
    By pablo_opc in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 18-09-2006, 09:01
  2. Z20let Throtle Responce With Oe Dump Valve Deacivated
    By THE GREEK COUPE in forum Turbo Petrol Engines inc. Transmissions
    Replies: 3
    Last Post: 14-10-2005, 07:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •