Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: No speedo lights or heater control lights

  
  1. #1
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    No speedo lights or heater control lights

    hi all

    have been changing the bulbs on my heater control panel to LED's the last few days.

    Today, after finishing soldering in new LED's for the push button switches, i pluged it back in to test it, and the two twist lock LED's wont light, theyre not the wrong way round as ive tried them both ways, and upon doing a little testing i found that there is 12V being supplied to both sides of the LED!

    Now iive also noticed my speedo illumination bulbs arent working either! ive taken the dials out and checked the bulbs and they havent blown. i also noticed that if you turn the head lights on and adjust the dimmer, the MFD does not dim as it usually would (the MFD illuminates normally other than this)

    sorry if that dont make sense, im tired!

    any help much appreiciated!

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    So you are missing a earth the the LED's?

    This sounds a bit strange as i'm sure the earth would be used for other things to in the speedo panel so other things wouldn't work

    I can only sugest that you go over everything again to make sure you haven't dislodged something
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    now that im awake and a bit more with it, ive done a bit more testing and realised i havent got 12V both sides of the bulb, i actually have no power going to it at all.

    the two wires which connect to the bulbs are both grounded, where as one should be live (a grey and green cable)

    im fairly confident no fuses have blown. could this be a relay?

    also instrument illumination bulbs arent working (and are not blown)

  4. #4
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    according to the haynes, the grey/green wire goes to multi-timer? anyone know what that is.

    Autosparks, have had a goodlook over everything, cant see anything obvious, also the actual hetaer blower control works, and the LED's for the push switches work, this is confusing me a bit now!

  5. #5
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    The multitimer is built into the fuse box as far as I know

    I'd double check the fuses first and then check the power comming for the headlight/dimmer switch
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  6. #6
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    okay will have a look now. cheers

  7. #7
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    all fuses are 100% definately okay. cant figure out how to remove the headlight switch....

  8. #8
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,743
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    There's a how to on it HERE
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  9. #9
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    okay mate, got the switch out,, big red has 12V on it, big yellow is grounded, brown is grounded, green/grey is grounded....what am i looking for matey?

  10. #10
    Status
    Offline
    llihzag's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    403
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    there are actually two green/grey, one bigone small, the small one has 12V on it when the lights are switched on, the big one is grounded

Page 1 of 3 123 LastLast

Similar Threads

  1. heater control lights and speedo lights
    By brad822 in forum Electrical
    Replies: 3
    Last Post: 26-07-2011, 15:20
  2. Heater control lights
    By domino in forum Electrical
    Replies: 6
    Last Post: 20-03-2007, 20:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •