Results 1 to 9 of 9

Thread: Regals phase 3 with VXR turbo prob

  
  1. #1
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Regals phase 3 with VXR turbo prob

    Hi all,

    I've posted this thread to the Astra chat forum but I guess this is the most appropriate place to do so...

    I have a Zaffy GSI with phase 3, downpipe, standard exhaust, 9lt side mounted intercooler, vxr turbo with standard vxr wastgate, powerpipe, KN pannel filter, iridium spark plugs.

    The car has made 280BHP on the rollers, and I am about to fit camshafts and exhaust
    I experience the following problem: When in full throtle under load (say 4th the car overboosts at 1,7bar and the holds steady 1,3-1,35 untill 5500rpm then drops to 1,1-1,2Bar until 6200 rpm.

    The overall performance is great but I experience the following problem during the 1,7 overboost: Sometimes (not all times) when peaking at 1,7 (3200 RPM) the engine makes small drawbacks, like it is cutting fuel, and when the boost comes down to 1,5 it is normal again.

    Tech2 does not raise any error (no missfires or anything else) whatsoever and no engine lights come on when that happens.

    Let me note again that the problem sometimes does not happen.

    Has any of you experienced something like that?

    Many told me about getting new spark plugs, mine are Denso IK24 with 40Kmeters already....

    any other opininons?

    Cheers

  2. #2
    Status
    Offline
    Matte's Avatar
    AOC Regular
    Join Date
    Jul 2006
    Posts
    117
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    talk to seaniboy, his car was or is i think doing the same thing. Well his is to do with the charge temp being to high. the ecu cuts the igintion.

  3. #3
    Status
    Offline
    aberdeenGSI's Avatar
    AOC Regular
    Join Date
    Dec 2004
    Posts
    145
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds to me ur injectors are maxing out u mite need to upgrade to bigger ones.

  4. #4
    Status
    Offline
    bally_gsi's Avatar
    AOC Fanatic
    Join Date
    Aug 2004
    Posts
    544
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I,m running the same spec but with bigger injectors and i think that 1.7 overboost is a little on the high side. Have you adjusted your acuator at all, if so wind it down a tad. get the bigger injectors and 80mm AFM and it should solve the problem
    Astra Gsi Turbo... With a few choice mods

  5. #5
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thank you m8s!!

    Will bigger injectors and 80mm AFM work with the same software ?

  6. #6
    Status
    Offline
    trickyb's Avatar
    AOC Fanatic
    Join Date
    Aug 2005
    Posts
    954
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Your running too much boost for standard injectors, max on standard injectors is about 1.45 bar.

  7. #7
    Status
    Offline
    Jass's Avatar
    AOC Regular
    Join Date
    Feb 2004
    Posts
    199
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by pablo_opc
    Hi all,

    I've posted this thread to the Astra chat forum but I guess this is the most appropriate place to do so...

    I have a Zaffy GSI with phase 3, downpipe, standard exhaust, 9lt side mounted intercooler, vxr turbo with standard vxr wastgate, powerpipe, KN pannel filter, iridium spark plugs.

    The car has made 280BHP on the rollers, and I am about to fit camshafts and exhaust
    I experience the following problem: When in full throtle under load (say 4th the car overboosts at 1,7bar and the holds steady 1,3-1,35 untill 5500rpm then drops to 1,1-1,2Bar until 6200 rpm.

    The overall performance is great but I experience the following problem during the 1,7 overboost: Sometimes (not all times) when peaking at 1,7 (3200 RPM) the engine makes small drawbacks, like it is cutting fuel, and when the boost comes down to 1,5 it is normal again.

    Tech2 does not raise any error (no missfires or anything else) whatsoever and no engine lights come on when that happens.

    Let me note again that the problem sometimes does not happen.

    Has any of you experienced something like that?

    Many told me about getting new spark plugs, mine are Denso IK24 with 40Kmeters already....

    any other opininons?

    Cheers

    With the increase in boost, wouldn't you need to keep the fueling going too? I would have thought either a fuel pump or bigger injectors would have solved the trick?? (i might be wrong) How are your a/f ratios??

  8. #8
    Status
    Offline
    pablo_opc's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    29
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    A/F ratios are fine!

    THe problem does not happen all the time, I have noticed that after hard use (now the temp in Greece is about 35 C) for about1 hour in the motorway, the car has no problem, it will overboost to 1,7 with no hesitation, but most of other times it is like it is trying to get boost down to 1,5Bar. From 1,5 and downwards I do not have any problem.

    Let me ask you again, do I hae to switch to new s/w (now I have regals phase 3 high boost) if I put larger injectors and AFM??

    I will try also to clean the AFM,

    Thanks again!

  9. #9
    Status
    Offline
    sxi boy's Avatar
    AOC Obsessed
    Join Date
    Feb 2004
    Posts
    1,420
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'd let the AFM be if i was you mate... prob be more trouble

Similar Threads

  1. Regals phase 5
    By slinkysilverturbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 1
    Last Post: 22-12-2005, 13:58
  2. EDS/Regals Phase 4
    By LordNikon in forum Turbo Petrol Engines inc. Transmissions
    Replies: 42
    Last Post: 21-09-2004, 22:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •