Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: My Car Is Broke!!!

  
  1. #1
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    My Car Is Broke!!!

    Hello people, i think it's safe to say that there is something wrong with my car. It's making dodgy spluttering noises when i rev it. At first i thought i just had water in the engine as i had just washed it but i got a friend of mine to have a look and he said it's the Cat. If it is, what route do i take? I really need something doing today because it is TOTALLY eating my petrol! - and i NEED to drive it.

    Cheers.

  2. #2
    Status
    Offline
    car.crash's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Posts
    1,036
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    how do you know its the cat. are you sure it isnt a missfire

  3. #3
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    i would look at the plugs first up mate

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'm with Danny on this one....Get the plugs checked and change em if necessary - sounds like a definite spark plug related issue

    Maybe give it a good service too while ur at it... new filters and fluids all round

  5. #5
    Status
    Offline
    KrisC's Avatar
    AOC Obsessed
    Join Date
    May 2006
    Posts
    2,047
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Deffo sound's like it's missing.
    Astra SRi Turbo
    281|317

  6. #6
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by GeordieBandit
    I'm with Danny on this one....Get the plugs checked and change em if necessary - sounds like a definite spark plug related issue

    Maybe give it a good service too while ur at it... new filters and fluids all round
    My friend done a compression test thinggy, i don't know what it's all about but he said the plugs are fine. I don't know for definite that it's the Cat but there's a rumbling noise coming from that area.

  7. #7
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i know it sounds obvious but I presume youve checked the exhaust system for leaks?

  8. #8
    Status
    Offline
    nasayr's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had the same on my mums 1.6 vectra, does it sound really loud on start up? we ended up putting a new cat in, and all was sorted, fuel economy has gone up too. we paid £280 for a full system inc. cat.
    "Don't waste your time on jealousy. Sometimes you're ahead, sometimes you're behind. The race is long, and in the end it's only with yourself"

  9. #9
    Status
    Offline
    vxgsiturbo's Avatar
    AOC Fanatic
    Join Date
    Feb 2006
    Posts
    877
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like your cat it either blocked or reattling both of which will end up u replacing the cat

  10. #10
    Status
    Offline
    Lorne's Avatar
    AOC Obsessed
    Join Date
    Jul 2005
    Posts
    1,995
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nasayr
    had the same on my mums 1.6 vectra, does it sound really loud on start up? we ended up putting a new cat in, and all was sorted, fuel economy has gone up too. we paid £280 for a full system inc. cat.
    Yeah loud at start up, there's no power in the car at all. Might take it up Kwik Fit tomorrow and see what they think .... Anyone had experience with Kwik Fit?

Page 1 of 2 12 LastLast

Similar Threads

  1. My dad broke my AOC Mug!!
    By ssa17WS in forum Chit Chat and a Warm Welcome!
    Replies: 10
    Last Post: 20-05-2011, 17:30
  2. broke down again!
    By idi in forum Zafira Discussion & Chat
    Replies: 9
    Last Post: 07-01-2010, 23:36
  3. Help. I've broke my PC.
    By Moffat in forum Chit Chat and a Warm Welcome!
    Replies: 11
    Last Post: 01-12-2008, 01:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •