Results 1 to 9 of 9

Thread: Bloody Kenwood

  
  1. #1
    Status
    Offline
    Opel Astra's Avatar
    AOC Newbie
    Join Date
    Jan 2006
    Posts
    18
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Bloody Kenwood

    I have recently got my hands on kenwood headunit with cd changer and installed it but i get interferance from car engine through the 6 x 9s also sub pops etc.

    There are two earths from the amp even tryed to put direct earth from the battery and also by passed the power control with live from battery but nothing.

    Funny thing is if i unplug the power control from the head unit it works fine through normal speakers. Cant work out whats pumped is it the head unit the sub the speakers or the amp? I have the spl amp from motorworld

    HELP!!!!!!!!
    Super Smashing Great

  2. #2
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Is the power cable and RCA leads running down the same side of the car?
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  3. #3
    Status
    Offline
    LIAM-SXI's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    978
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like you have blew your headunit matey did you disconect the power cables from the amp and the fuse from the power cable from the amp?
    i may be wrong but sounds like you have blew your headunit mate sorry!
    Got XBOX LIVE? Gimme a game!
    Gamertag: DOGBOY14

  4. #4
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by LIAM-SXI
    sounds like you have blew your headunit matey did you disconect the power cables from the amp and the fuse from the power cable from the amp?
    i may be wrong but sounds like you have blew your headunit mate sorry!
    Based on what?
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  5. #5
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    firstly make sure you've routed power cable away from speaker cables, then make sure all earths are fine. If that improves it a little then you may need a noise supressor.
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  6. #6
    Status
    Offline
    LIAM-SXI's Avatar
    AOC Fanatic
    Join Date
    Mar 2006
    Posts
    978
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    because you hear the engine interference when putting revs on through the headunit. this happens when you blow your headunit. well thats what i heard
    its summit to do with touching metal with a cable (think the amp power cable or rmote if they are connected to the H/U and the amp.
    probs wrong sorry if i am matey!
    Got XBOX LIVE? Gimme a game!
    Gamertag: DOGBOY14

  7. #7
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    That usually just means its badly earthed or wired
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  8. #8
    Status
    Offline
    RobW's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    3,411
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I had a coil suppressor in a car once and it did cure this problem.


    Cant guarantee it will yours though. As Dave said, check the cables and earth points and if its earthed to the car body, make sure its making good contact.

  9. #9

Similar Threads

  1. Kenwood BT100 and Kenwood IP200
    By JazzyJust in forum ICE Mk4|G
    Replies: 2
    Last Post: 27-02-2010, 18:06
  2. Kenwood Screen + Kenwood Sat nav
    By f4af100uk in forum ICE Mk4|G
    Replies: 10
    Last Post: 27-05-2007, 02:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •