Results 1 to 6 of 6

Thread: ECU Fuse and Engine Management Light

  
  1. #1
    Status
    Offline
    Kilmar's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    ECU Fuse and Engine Management Light

    Hi All

    I'm an ex-pat living in Egypt, with a 2006 1.6 16 valve Ecotech saloon (CD model - not available UK).

    A lovely motor, loves the long straight desert roads, but I have a small issue...

    The sun visor broke, and in trying to fix it I shorted the mirror light, blowing the fuse. Now, to make things more interesting the instruction manual is in Arabic (which I do not read!) and I could not find the fuse box, anywhere....

    In the process of looking for the interior light fuse, which I could not find, I removed every fuse that I could find, i.e. the one's under the bonnet... including (I would imagine) the ECU fuse. Yeah, okay. I am a muppet...

    I have now found the fuse box, behind the driver's cubby hole, and replaced the interior light fuse. The only problem is that the Engine Management light now wont go out, probably due to the ECU fuse being removed?

    Now my nearest Opel garage is 1000 km away (yup, that's 600 miles) and I would like to know three things:

    1. Have I caused a major problem with the ECU?
    2. Will driving it 600 miles do it any harm?
    3. Is there a work around that I can do to get the ECU to reset?

    My own stupid fault I know, but your help would be appreciated!

    Many thanks

    Dan

    Also, if anyone knows of where I can download a copy of the Astra's manual in English it would be a great help

  2. The following members like this post:


  3. #2
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    Hi Dan and welcome to Astrasport.

    firstly - a manual in english for you - http://www.vauxhall.co.uk/vx/static/...traApr2003.pdf

    I don't think you've caused a major with the ECU, it's more than likely just upset with you. Try disconnecting the battery for about 30mins first and see if that helps - sometimes does, sometimes doesn't

  4. #3
    Status
    Offline
    Kilmar's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for such a quick response!

    I'll try disconnecting the battery as you suggest and see what this does.

    Fingers crossed...

    Dan

  5. #4
    Status
    Offline
    Kilmar's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Well, bizarrely, when driving home from the office to disconnect the battery, after several miles the 'check engine' light went out.

    Well, that solved that then!

    Thanks for the link to the manual, it makes far more sensse to me than the Arabic version!

    Dan

  6. #5
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    Even better - sometimes they do that too.

    Amazing things are the Voodoo boxes we call ECU's

  7. #6
    Status
    Offline
    Kilmar's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Here's a picture of one of those long straight desert roads I was talking about...


Similar Threads

  1. Replies: 2
    Last Post: 31-08-2009, 21:09
  2. Engine management light - fuse?
    By Norseman in forum Electrical
    Replies: 4
    Last Post: 24-03-2008, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •