Results 1 to 7 of 7

Thread: Abs + Tc Light Problem??

  
  1. #1
    Status
    Offline
    ash_corsa's Avatar
    AOC Regular
    Join Date
    Nov 2005
    Posts
    241
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Abs + Tc Light Problem??

    when i start my car, sometimes the TC and ABS lights stay on instead of going out with the other lights
    but when you turn car off, then turn ignition on and wait for them to go out then start the car again its fine
    anyone else get this? why does it do this?
    cheers
    *** Vauxhall Astra SRi 2.0 16v ***

  2. #2
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Sounds like a Donald Hub Sensor to me. At the moment it's only an intermitent problem, but with mine it got worse and worse.
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  3. #3
    Status
    Offline
    dodger's Avatar
    AOC Fanatic
    Join Date
    May 2005
    Posts
    709
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As Jace said, had same problems with mine had it Tech2 and showed the near side front hub faulty, got new one fitted which solved the problem.

  4. #4
    Status
    Offline
    AdzP's Avatar
    AOC Fanatic
    Join Date
    Jan 2006
    Posts
    755
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    When my ABS & TC lights were coming on Vaux seemed to pin point the ABS control unit at £ 558, car didn't feel any different under braking when these were showing. Cured the problem though, no more lights on the dash, dunno if that is worth checking out.
    Arden Blue VXR / itg / Full Remus / 259bhp & 262lb ft

  5. #5
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Check the hub sensor first! £83 from Auto Vaux delivered!
    01924 376003
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  6. #6
    Status
    Offline
    ash_corsa's Avatar
    AOC Regular
    Join Date
    Nov 2005
    Posts
    241
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    by hub do you mean wheel bearing as theyre all in one??
    ive changed all of the bearings except one wich is the n/s/f one!!
    i can get the hubs for £62 each localy
    cheers
    Ash
    *** Vauxhall Astra SRi 2.0 16v ***

  7. #7
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yep, hub, wheel bearing, hub sensor - all one entity.
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

Similar Threads

  1. side light/brake light problem. please help
    By jp6 in forum Electrical
    Replies: 4
    Last Post: 19-10-2012, 09:44
  2. Interior light and head light buzzer problem
    By mitz in forum Electrical
    Replies: 4
    Last Post: 28-06-2012, 15:54
  3. Dash light, sidelights and rear fog light problem
    By boblopez in forum Electrical
    Replies: 0
    Last Post: 07-12-2010, 10:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •