Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: My baby won't dump!

  
  1. #1
    Status
    Offline
    gsi_paul's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    69
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    My baby won't dump!

    Hmmm that title sounds dodgy! Anyway hi all, just got my GSI and first post on the site so HELLO!
    I've had a Bailey DV-26 on there for about a month and it has all been working fine. Except today driving down the road I noticed it wasn't venting any air. All hoses are connected, no air is escaping. I've removed the dump valve and the piston moves when I push it so I'm stumped!
    Anybody else had this problem?

    Paul

  2. #2
    Status
    Offline
    fingz999's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Posts
    2,359
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Car running ok?? is it still giving full boost?
    Heading back to the world of AOC

  3. #3
    Status
    Offline
    gsi_paul's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    69
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yeah seems to be running OK. Still pulling as well as it did. It seems to be making a little flutter noise out the exhaust (but it might have been there before and I could have just not noticed by paying too much attention to the whoosh!)

  4. #4
    Status
    Offline
    JP_Turbo's Avatar
    AOC Regular
    Join Date
    Mar 2006
    Posts
    112
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had this problem when i first fitted my powerpipe with the dump valve outlet. I fitted it, worked fine for about 2mins, and then it wouldnt dump. I found the problem to be some pipe getting in the way of the vacuum hose which was crimping the vacuum hose in half - so nothin could flow.

    i cable tied the pipe out the way and all was good. This probably isnt the case for you, but just a thought....
    JP driving SRI-T, totally standard, whats the best way forward!?

  5. #5
    Status
    Offline
    gsi_paul's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    69
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Thanks for the input but all the pipes seem ok. I did wonder if it might have got too hot - was sitting in traffic for a while. I'll give it another go when the engine has cooled down a little.

  6. #6
    Status
    Offline
    888rich's Avatar
    AOC Obsessed
    Join Date
    Aug 2005
    Posts
    2,550
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    has the spring inside the dump valve gone pete tong - my c20 let stopped hissing - ended up being a weak spring in the bailey

  7. #7
    Status
    Offline
    Welsh_Cruiser's Avatar
    AOC Fanatic
    Join Date
    Jun 2005
    Posts
    495
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I Had A Problem Were My Dump Valve Went Very Quiet An Power Was Reduced...I Found Out My Vectra Intake Adaptor Had Come Of My Air Box...Pushed It Back On An It's Fine Now
    Arden Blue Astra GSi

  8. #8
    Status
    Offline
    gsi_paul's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    69
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It's really weird because as I said before the engine is running fine. It's like there isn't a big enough vacuum being created to pull the valve open. Could anything have happened to cause a reduced vacuum or is it likely that the spring in the dump valve is causing the piston to be too stiff? How much force should I need to apply to the piston to make it move?

  9. #9
    Status
    Offline
    Turbo Keith B's Avatar
    AOC Regular
    Join Date
    Nov 2005
    Posts
    194
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Maybe the vacum box down the back of the engine is knackered.

  10. #10
    Status
    Offline
    gsi_paul's Avatar
    AOC Newbie
    Join Date
    May 2006
    Posts
    69
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Oh don't say things like that! I'm gonna take the dump valve apart tomorrow and have a look.

Page 1 of 2 12 LastLast

Similar Threads

  1. Can you service a dump valve? Also a couple of questions on dump valves!
    By sam_888 in forum Turbo Petrol Engines inc. Transmissions
    Replies: 14
    Last Post: 07-07-2009, 17:30
  2. My baby won't dump!
    By gsi_paul in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 09-05-2006, 15:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •