Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Engine Managment Light

  
  1. #1
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Managment Light

    My engine management light has been coming on at random points but nothing seems to be affected.

    It came on when I first started up, when I got up the road 3 miniutes, stopped for 2 mins and started it again it didn't come on again. Did it again about 3-4 hrs later. (During this time I started & stopped a few times as I am a self employed courier but it has not done this before and I have been delivering with it since January.)

    Is there anything I can do to check what it is detecting without paying a garage £30-£35 to plug it in?

    Cheers, Brian
    2005 SRi Turbo

  2. #2
    Status
    Offline
    Shahid's Avatar
    AOC Fanatic
    Join Date
    Apr 2005
    Posts
    475
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    car and engine details would help. If you have a mk4 pre-2000 you should be able to read the codes using the paperclip trick.

  3. #3
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Management

    Car is a Mk3 2.0 16v Eco

    Cheers
    2005 SRi Turbo

  4. #4
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    You can read the fault codes yourself - its dead easy.

    Go to http://www.topbuzz.co.uk/ - click "information", then "technical" and the scroll down to "reading ECU fault codes"

    You've got a Simtec 56.1 ECU btw

  5. #5
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Management

    Thanks for that, I got the paperclip out and it comes up with two codes:

    0335 - Crank Sensor
    0340 - Camshaft Sensor

    Ive got the Simtec 56.5 with 16 pins apparently.

    I had the crank sensor done 20,000m ago, is this all they last? Cost me near £85. Are they both easy enough to do my self as I would like to have a go to save a bit of cash if I can.

    How can I reset the fault codes and remove them after as well.

    Cheers, Bri
    2005 SRi Turbo

  6. #6
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If im not mistaken I think u can clear the fault codes by disconnecting the battery and leaving it disconnected for about 30mins to an hour! or something like that....someone will confirm later.

  7. #7
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Management

    Those codes I had when the engine was off and I reset them. I had to wait until it happened again and this is what I got:

    0335 - Crank sensor (engine off again as nothing comes up when i start engine)
    0100 - Mass air flow sensor
    0351 - Ignition coil 1 & 4
    0352 - Ignition coil 2 & 3

    What do you think is wrong and what should i do first?

    Cheers, Bri
    2005 SRi Turbo

  8. #8
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Management

    Anyone know what might be wrong?

    Cheers, Bri
    2005 SRi Turbo

  9. #9
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    Engine Management

    Still need help please!!!
    2005 SRi Turbo

  10. #10
    Status
    Offline
    brainreyd's Avatar
    AOC Premium Member
    Join Date
    Aug 2003
    Drives
    Astra Mk5 2.0 SRi T 200 & Astra Mk4 1.8 SRi
    Location
    Redruth
    Posts
    405
    Mentioned in
    0 Post(s)
    Quoted
    4 Post(s)

    DIS Module

    Could this be something with the DIS Module? Plugs? Leads?

    Cheers, Bri
    2005 SRi Turbo

Page 1 of 2 12 LastLast

Similar Threads

  1. Engine Managment Light !!!! :-S
    By DanMc_321 in forum Electrical
    Replies: 4
    Last Post: 08-09-2009, 21:12
  2. Engine Managment Light
    By Animal_Winnie in forum Electrical
    Replies: 4
    Last Post: 26-02-2009, 08:37
  3. hi this is regarding my engine managment light
    By joepooley in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 20-01-2009, 18:21
  4. Engine managment light..HELP
    By Gilly in forum Electrical
    Replies: 22
    Last Post: 14-10-2004, 19:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •