Results 1 to 7 of 7

Thread: fuel cap problem

  
  1. #1
    Status
    Offline
    Andy's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    5,313
    Mentioned in
    5 Post(s)
    Quoted
    0 Post(s)

    fuel cap problem

    there is a small prob with my sri-t i will be getting tomorrow,

    the fuel cap doesnt seem to like locking, when you lock the car it pops open unless you hold it back in place,

    my assumption is in my current astra the cap must have some type of spring that closes the flap when its half way open etc but the new one this doesnt seem to happen?

    any ideas? or should i just take the flap off and see if i can notice anything wrong?

    didnt know if this was a common prob?
    Drives - 08 Astra SRi XP 1.9CDTi 150

    Beer is living proof that God loves us and wants us to be happy.

  2. #2
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    no spring as far as i recall. try locking the car whilst holding the flap open to see if u can see the mechanics working as they should. cant see what use taking the actual flap off will achieve as the mechanics (and the problem) will most likely be on the car side and not the flap. give it a go once u get the car and we can hopefully guide u in the right direction.
    Definitely no spring as far as i know of.

  3. #3
    Status
    Offline
    Andy's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    5,313
    Mentioned in
    5 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by GeordieBandit
    no spring as far as i recall. try locking the car whilst holding the flap open to see if u can see the mechanics working as they should. cant see what use taking the actual flap off will achieve as the mechanics (and the problem) will most likely be on the car side and not the flap. give it a go once u get the car and we can hopefully guide u in the right direction.
    Definitely no spring as far as i know of.
    o,
    the locking mech works perfectly, i was trying to have a look at it in the show room, but couldnt sort it out,
    i thought the flap was a little loose but the one on my current astra is the same so im not sure,

    ill compare the 2 tomorrow so hopefully should find the prob,
    Drives - 08 Astra SRi XP 1.9CDTi 150

    Beer is living proof that God loves us and wants us to be happy.

  4. #4
    Status
    Offline
    GB's Avatar
    AOC Obsessed
    Join Date
    Jan 2006
    Location
    Leeds
    Posts
    21,918
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    just had a look at mine - defo no spring altho when the cap is about 2inches from closed it will naturally spring back towards the closed position but not fully home. The only thing u can do is wait till u get it and compare them side by side. Let us know how u get on cos it'll be good to know just in case it is a common fault!

  5. #5
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    From your description, is sounds like the catch that holds the cover shut is a bit guff, so that when you lock the car, the central locking rod misses the hole on the back of the cover, and pushes it open.

    Get some piccies of the back of the cap - I'll be able to tell you if that's what it is

  6. #6
    Status
    Offline
    Andy's Avatar
    AOC Obsessed
    Join Date
    Jan 2005
    Posts
    5,313
    Mentioned in
    5 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Ffoeg
    From your description, is sounds like the catch that holds the cover shut is a bit guff, so that when you lock the car, the central locking rod misses the hole on the back of the cover, and pushes it open.
    thats exactly what it seems to be doing to me,

    when it arrives i will get some pictures and compare it to my current astra and see if i can suss it out,
    Drives - 08 Astra SRi XP 1.9CDTi 150

    Beer is living proof that God loves us and wants us to be happy.

  7. #7
    Status
    Offline
    Ffoeg's Avatar
    2170:01:06
    Join Date
    Jun 2003
    Posts
    34,591
    Mentioned in
    2 Post(s)
    Quoted
    0 Post(s)
    Have a look to see if the loop on the back of the cap is worn away - it should be round, with a pretty much contact thickness loop. But I suspect that as the rod has been missing the hole it will be deformed or ramped in some way.

    might be fixable, it it might need a new cap - hopefully it'll be the first

Similar Threads

  1. Fuel problem help
    By cdti carl in forum Diesel Engines inc. Transmissions
    Replies: 13
    Last Post: 10-04-2012, 15:04
  2. Bi-fuel problem
    By Archie in forum Electrical
    Replies: 1
    Last Post: 18-07-2009, 09:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •