Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: problem with my z20let

  
  1. #1
    Status
    Offline
    nasayr's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    problem with my z20let

    car: astra coupe turbo
    have fitted a baileys d/v, and a stainless open air filter..
    problem is the turbo spools up nicely, but if you floor it, it cuts out and feels like a normal 2.0!
    also noticed a funny darth vadar breathing sound when releasing the throttle at around 1.5k revs, its coming out of the filter, but i thought the filter was only ingoing air, and not outgoing??

    i havnt disabled the oe valve, but just blocked off the vaccuum hose..

    any ideas?could it be the actuator needs adjusted?how is this done?and how much thread should be showing from the bottom?

    thanks..
    "Don't waste your time on jealousy. Sometimes you're ahead, sometimes you're behind. The race is long, and in the end it's only with yourself"

  2. #2
    Status
    Offline
    Gnasher's Avatar
    AOC Obsessed
    Join Date
    Oct 2005
    Posts
    1,897
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It should be fine. The 'Darth Vader' noise is normal - mine does it. It is apparently the last bit of air being forced back through the turbo, but I will stand corrected probably!

    Does the new DV actually work (Does it 'dump')? If it doesn't, check is that in fitting the DV you havent left the pipe off anywhere that runs to the original/new DV - it sounds like you have some sort of an air leak to me matey! Or you have fitted the DV incorrectly - Dont adjust the actuator, it should be fine as it is.
    The pipe off the back of the new DV should just drop down th the inlet manifold just below it - about 6 to 12 inches of vacuum pipe depending where your DV is fitted.
    2006 Astra VXR on 19's in Arden Blue
    ExhaustsUK Catback, Eibach Sportlines, DS Ultima, Roose hose kit, Forge recirculating dump valve, Full self modded SMD conversion

  3. #3
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by nasayr
    i havnt disabled the oe valve, but just blocked off the vaccuum hose..
    That is your propblem. WHo told you to do this?

    The OE dump valve needs pressure each side of it to keep it in place (i.e. closed). By blocking to the feed to it, it is now allowed to blow open at the slightest pressure as there is no pressure on the other side holding it closed.

    Go and unblock the pipe to the OE dump valve - should work better. If you want to dissable the OE valve, you will need the spacer kit.
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  4. #4
    Status
    Offline
    AndyGSi's Avatar
    AOC Fanatic
    Join Date
    Feb 2005
    Posts
    775
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Get the induction kit off and fit the tried and tested panel filter and de-restricted airbox, much better, should stop the cutting out, as the air flow through the filter will be confusing the life out of the AMM
    Astra GSi Turbo, SOLD


  5. #5
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Andy - I should be fitting an induction kit to my car today - that is if what needs collecting from the parcel depot is indeed the filter.
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  6. #6
    Status
    Offline
    BenC's Avatar
    AOC Obsessed
    Join Date
    Dec 2003
    Posts
    2,574
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by AndyGSi
    Get the induction kit off and fit the tried and tested panel filter and de-restricted airbox, much better, should stop the cutting out, as the air flow through the filter will be confusing the life out of the AMM

    Eeeer Im running a cone filter with no problems!??
    Corsa C LEH 4x4?

  7. #7
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I was too for a while but got fedup of hearing the turbo spool up all the time (Must be getting old)

  8. #8
    Status
    Offline
    BenC's Avatar
    AOC Obsessed
    Join Date
    Dec 2003
    Posts
    2,574
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by lee gsi
    I was too for a while but got fedup of hearing the turbo spool up all the time (Must be getting old)

    I probably would aswell if i used the car allot!, cant really hear it when you have the stereo on anyway! but i know what you mean!


    I put the airbox back on, but it felt so much slower that i put the cone back on!
    Corsa C LEH 4x4?

  9. #9
    Status
    Offline
    AndyGSi's Avatar
    AOC Fanatic
    Join Date
    Feb 2005
    Posts
    775
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by BenC
    Eeeer Im running a cone filter with no problems!??
    which filter are you using ben? maybe its the stainless filter.

    You must agree that it would be an idea to try it with the original setup, jut to cross it off the list
    Astra GSi Turbo, SOLD


  10. #10
    Status
    Offline
    BenC's Avatar
    AOC Obsessed
    Join Date
    Dec 2003
    Posts
    2,574
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by AndyGSi
    which filter are you using ben? maybe its the stainless filter.

    You must agree that it would be an idea to try it with the original setup, jut to cross it off the list

    Im not sure what you mean!

    running a cone filter you get all sorts of strange noises from the turbo, but most of all you can hear the turbo spool up and the recirc valve opening when you lift off!

    if you block off the vacuum line to the recirc valve and run a cone filter you get thats turbo stall sound like a cossie usually has!

    the car runs fine like this but it will probably stuff up your turbo eventually!
    Corsa C LEH 4x4?

Page 1 of 2 12 LastLast

Similar Threads

  1. Z20LET problem pls help
    By RAXSTAR in forum Turbo Petrol Engines inc. Transmissions
    Replies: 16
    Last Post: 09-12-2012, 15:33
  2. Problem z20let
    By Chimoako in forum Turbo Petrol Engines inc. Transmissions
    Replies: 2
    Last Post: 30-05-2009, 15:48
  3. z20let problem
    By l11wne in forum Turbo Petrol Engines inc. Transmissions
    Replies: 4
    Last Post: 29-01-2007, 14:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •