Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Big probs with Z20 let

  
  1. #1
    Status
    Offline
    mike659's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Big probs with Z20 let

    Hello all I am after bit of help
    I own a 2001 astra coupe turbo
    Problem is missfire between 3000-4000rpm which put emmision light on, put on tech 2 and showed missfire 2,3 and 4. Fuel trim rail 1.
    put new plugs in and cleared codes and run worse. so put on new coil pack but no different.
    then i,ve removed one of the cats. checked for vacuum leak. checked injectors. changed oil and filter, new fuel filter, put fuel system cleaner in. and giving it a compresion test. still the same. so give it to vauxhall boys on fridy and they said that the ecu had gone. they changed that then said the first lamba was not fluctuating and givin constant reading of 450 so they changed that today sat. then say theres slight hesitation on low revs and they think it the amm.
    Go pick it up and pay the £691.01 and drive away get 200 yrds and missfires again, go back but only mastersh*t techs there and say come back monday. after moaning for ages get a car off them.
    just wondering if anyone has any ideas as i payed all that money
    £148.50 labour
    £11.84 non return valve ( i broke this on top breather)
    £334 ecu
    £15 car pass
    £78.75 lamba sensor
    £102.92 VAT

    and the want anoter £89 for the amm as they think it might be that now but the tech 2 not showing anything

    Could it be that is the problem and thats what is was all along but they put ecu on.
    Need help got to go back on monday.

  2. #2
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    If I had any problems like that, the AMM would be the first thing I check every time. I even have a good spare, just so I swap it over when I get any probs. Last time my AMM went, I had seriuos missfires and hesitation.
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  3. #3
    Status
    Offline
    markja's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    1,890
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i had the same problem, i got told my ecu was *******, its utter crap, if you havnt done so already, change the 2nd o2 sensor, then your AMM, i bet it solves your problem, it took me 6mths to get it sorted, my local dealer had no clue at all
    YOUR FRIENDLY WINDSCREEN MAN

  4. #4
    Status
    Offline
    Scottyboy's Avatar
    AOC Obsessed
    Join Date
    Jun 2004
    Posts
    5,750
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    As Mike says - I'd always, always try the AFM/AMM first - we have a couple of spares in the garage.

    Worth checking the O2 sensor - but maybe worth checking the fuel pressor regulator - just a guess really as they seem to have checked almost everything else. Oh - and I don't see why you chould have to pay for parts that don't solve your problem? if the ecu was not at fault - refuse to pay and have your old one put back on at no cost?

  5. #5
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Also - did you get the old ECU off them? It is probably fine and could be sold on eBay for a bit. Better still, get them to refund the work they did. I'd be seriously pissed with them if it happened to me.
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  6. #6
    Status
    Offline
    K3FUS's Avatar
    AOC Obsessed
    Join Date
    Nov 2004
    Posts
    5,752
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by MikeWarner
    Better still, get them to refund the work they did. I'd be seriously pissed with them if it happened to me.
    Ditto, what they did was not nessesary and therefore should be refunded (assuming you get your old parts refitted and give then the new ones back)
    Tell me what you've done, not what you're going to!

  7. #7
    Status
    Offline
    mike659's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    when i picked up the car only mastersh*t techs there no bosses so couldn't get any answers. Got to go there monday to see them. See what they say but want money back as what they done not done anything and car still the same so ecu couldn't really be at fault.

    I will get an amm ordered monday as well luckily can get parts at trade prices.

    Thank for all the help.

  8. #8
    Status
    Offline
    MikeWarner's Avatar
    AOC Obsessed
    Join Date
    Sep 2004
    Posts
    3,167
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mike - unfortunately you are not the only one to suffer like this. It seems that Vauxhall technicians get confused with the Z20LET. To be fair, the AMM does not get diagnosed by the ECU correctly, but the technicians should know this.
    8 Astras in a row! Can Anyone Beat That?
    Star Silver Astra Sporthatch SRi XP 1.9 CDTi (150PS)
    A Vauxhall site about Vauxhalls.

  9. #9
    Status
    Offline
    mike659's Avatar
    AOC Newbie
    Join Date
    Nov 2005
    Posts
    8
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    we have to remember there are vauxhall techs and they can barely turn the kettle on without help.

  10. #10
    Status
    Offline
    turboed's Avatar
    AOC Regular
    Join Date
    Sep 2004
    Posts
    81
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ihad the same and replaced the 1st lamba sensor then the air mass meter and That then sorted it

Page 1 of 2 12 LastLast

Similar Threads

  1. anyone else having probs?
    By Dani in forum Chit Chat and a Warm Welcome!
    Replies: 2
    Last Post: 11-09-2009, 19:17
  2. 1.7 tdi probs
    By keveff in forum Diesel Engines inc. Transmissions
    Replies: 0
    Last Post: 30-07-2009, 20:14
  3. abs tc probs...
    By leemarksmith in forum Electrical
    Replies: 8
    Last Post: 24-03-2007, 11:46
  4. msn probs
    By Vauxylady in forum Chit Chat and a Warm Welcome!
    Replies: 8
    Last Post: 12-11-2003, 18:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •