Results 1 to 5 of 5

Thread: well replaced the main lambda and still got the light on

  
  1. #1
    Status
    Offline
    mitch@evolution's Avatar
    AOC Regular
    Join Date
    Jul 2005
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    well replaced the main lambda and still got the light on

    finally got round to replacing the main cat lambda and ive still got the engine managment light on even did the ecu reset trick where u turn the key 20 times and it still came back on so im lost now on what to do, guess its just something thats going to stay on due to the conversion. Dont think it actually means anything being on as everything runs fine and i have no issues apart from the high fuel consumption but that may fix itself with the lambda now being on.
    Inspired Automotive Detailing and Valeting - Concours Approved
    www.inspired-automotive.co.uk

  2. #2
    Status
    Offline
    beastra's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Posts
    2,180
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Would a Tech 2 not find the problem ?
    MK4 Golf 1.8T, Euro Style

  3. #3
    Status
    Offline
    Browny_37's Avatar
    AOC Obsessed
    Join Date
    Jun 2005
    Drives
    Astra J SE 2.0CDTI
    Location
    Derby
    Posts
    1,356
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    try checking your earths, my m8 had a c20xe dropped in his corsa.....and he had problems with the lambda with it being a 3 wire lambda he checked the earth lead on it, cut so much off soldered a length of wire to the ecu as it should....and the other half to somewhere else.
    And that cured his rough running problems.

  4. #4
    Status
    Offline
    Skuzzle's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    3,427
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by mitch@evolution
    finally got round to replacing the main cat lambda and ive still got the engine managment light on even did the ecu reset trick where u turn the key 20 times and it still came back on so im lost now on what to do, guess its just something thats going to stay on due to the conversion. Dont think it actually means anything being on as everything runs fine and i have no issues apart from the high fuel consumption but that may fix itself with the lambda now being on.

    exactly as i've got except my fuel is fine
    Skuzzle - Powered by Badgerbyte Web & IT Services

  5. #5
    Status
    Offline
    mitch@evolution's Avatar
    AOC Regular
    Join Date
    Jul 2005
    Posts
    284
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the cars runs fine its just the fuel it uses its scary only done about 200 miles to 50 quid of fuel steady driving i darnt boot it. im going to see if the lambda makes it any better and the light is on for another reason.
    Inspired Automotive Detailing and Valeting - Concours Approved
    www.inspired-automotive.co.uk

Similar Threads

  1. Who (if anyone) has replaced their main engine fan?
    By GB in forum Turbo Petrol Engines inc. Transmissions
    Replies: 12
    Last Post: 23-04-2011, 18:14
  2. Bulb and fuse replaced, but no light
    By barterr in forum Electrical
    Replies: 5
    Last Post: 01-06-2010, 20:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •