Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Z20LET AFM / Air Flow Meter, have you ever replaced it ?

  
  1. #1
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Z20LET AFM / Air Flow Meter, have you ever replaced it ?

    I'm doing this poll because I'm on my 4th AFM and I'm going crazy ....
    I just wanna know if there's someone running a modded ECU without AFM problems

  2. #2
    Status
    Offline
    astragsiturbo's Avatar
    AOC Obsessed
    Join Date
    Aug 2004
    Posts
    1,643
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    yep twice.
    life's to fast to go slow. so get the turbo.

  3. #3
    Status
    Offline
    GSILady's Avatar
    Cameron Ginger Diaz
    Join Date
    Mar 2004
    Posts
    5,400
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    ....and me


  4. #4
    Status
    Offline
    LordNikon's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    18,952
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I ran mine on phase2 for a year with no AMM problems ! Got lucky i guess

  5. #5
    Status
    Offline
    GSI Mav's Avatar
    AOC Fanatic
    Join Date
    Nov 2004
    Posts
    382
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I have my GSI Turbo on EDS Stage 1 and have never had any AMM problems. Car has been remapped for about 6 months or so now.
    JDM WRX STi7 Subaru Impreza
    300bhp

  6. #6
    Status
    Offline
    Al's Avatar
    Turbo Jizz Golfer !
    Join Date
    May 2003
    Posts
    8,200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    1 change after 2 days of ownership

    Had to pay for it too, which bugged me when it should have been free from vx

  7. #7
    Status
    Offline
    AndyGSi's Avatar
    AOC Fanatic
    Join Date
    Feb 2005
    Posts
    775
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I bought a new one as I thought it was on its way out. put the new one in, a no difference, so now I have a handy spare.

    It been on more cars than I can remember, in an attempt to iron out poor running problems.

    I think that if you are running a tried and tested induction setup, and you are still cooking them, your driving style may have something to do with it, particularly with a remapped ECU.
    Astra GSi Turbo, SOLD


  8. #8
    Status
    Offline
    LordNikon's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    18,952
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Location and ambient air temps dont help IMO either. Whats the betting if everyone let us know when theirs failed the majority would be during summer months ???

  9. #9
    Status
    Offline
    KNIFFA's Avatar
    AOC Regular
    Join Date
    Feb 2004
    Posts
    275
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy

    Yep Two In Summer Steve

  10. #10
    Status
    Offline
    martin-GSI's Avatar
    AOC Regular
    Join Date
    Apr 2004
    Posts
    272
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Running CS2 and no problem (touch wood)

    Think that some also go when people re-oil airfilter and run different induction kits.

    How many have gone with out any mods what so ever. No de-resricted airboxes etc?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •