Page 1 of 4 1234 LastLast
Results 1 to 10 of 40

Thread: boost figures and behavior

  
  1. #1
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy boost figures and behavior

    I've just fitted an Autometer boost gauge on my Z20LET coupe.
    I noticed that boost suffers from an annoying hesitation when accelerating hard.

    The turbo boosts to 15psi, hesitates half a sec, then overboosts to 20psi and decrease back to 15psi, in 3rd 4th or 5th gear of course.
    I'm pleased by the 20psi overboost and 15psi hold, but I'm just wondering if this hesitation before the overboost is a normal thing or not.

    BTW, I'm running EDS phase 2 with 9ltr intercooler, derestricted airbox and k&n panel filter, stainless steel powerpipe with no "DV out", precat and sportscat from courtenay and bastuck "no middle silencer" exhaust !

    Thank you !

  2. #2
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    anyone ? P2 or CS3 owners with boost gauge ?

  3. #3
    Status
    Offline
    ashtal's Avatar
    AOC Regular
    Join Date
    Dec 2004
    Posts
    100
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Ive got the same problem mate. Narrowed it down to either injector or ecu or maybe even the map. Sorry i dont have a guage yet. I am running cs 3 from courtenay.

  4. #4
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    did you fixed the problem?

  5. #5
    Status
    Offline
    BenC's Avatar
    AOC Obsessed
    Join Date
    Dec 2003
    Posts
    2,574
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    could be bad fuel?

    Stick some octane booster in it and see if it goes away!

    I had to fill my gsi up at a petrol station renouned for crap fuel and low and behold every now and agin i was getting judder on hard acceleration, since then never had it again!
    Corsa C LEH 4x4?

  6. #6
    Status
    Offline
    coupe_turbo_jon's Avatar
    AOC Obsessed
    Join Date
    May 2005
    Posts
    1,946
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Have you tried an air flow meter, just a thought
    Astra Coupe Turbo Edition
    230bhp remap air and exhaust mods

  7. #7
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by coupe_turbo_jon
    Have you tried an air flow meter, just a thought
    have to try ...!

  8. #8
    Status
    Offline
    coupe_turbo_jon's Avatar
    AOC Obsessed
    Join Date
    May 2005
    Posts
    1,946
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Do, because those were the symtoms I was having when mine went
    Astra Coupe Turbo Edition
    230bhp remap air and exhaust mods

  9. #9
    Status
    Offline
    rakpeterson's Avatar
    AOC Newbie
    Join Date
    Jul 2005
    Posts
    56
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    had simmilar prob with mine. Thought it was maybe ecu or amm but it later turned out to be the actuator arm catching on the inside-side of the turbo heatshield. it was catching in a few places and would seem to hesitate then suddenly pick up again. Just a thought if youve removed/painted/etc. heat sheild like i did.
    MK4 Astra SRI 2.0 16v TURBO. SRI with 888 coupe running gear. 209.5 bhp 222lb/ft torque

  10. #10
    Status
    Offline
    mantamagic's Avatar
    AOC Fanatic
    Join Date
    Jun 2003
    Posts
    817
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    You have to remember that by the time your running 10psi of boost, the actuator has already fully cracked open.

    I think the boost issue may be down to the BCS (Boost Control Solenoid), which is the device the boost hose to the actuator comes from.

    It bleeds off back into the intake and may simply be slow in responding.

    It does exactly the same with my car.

    My car boosts up to 15psi hesitates then goes up to 17-18.

    On overboost it goes straight up to 20 without a problem.

    I'm sure I read about a similar issue being fixed by replacement of the BCS ?

Page 1 of 4 1234 LastLast

Similar Threads

  1. Low boost figures
    By ChrisBoom in forum Turbo Petrol Engines inc. Transmissions
    Replies: 13
    Last Post: 13-09-2010, 15:37
  2. VXR boost figures ??
    By Neilc in forum Astra Discussion & Chat
    Replies: 0
    Last Post: 06-11-2006, 20:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •