Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Loosing oil and oil smell?

  
  1. #1
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Loosing oil and oil smell?

    My Z20LET seems to be using oil a fair bit but I cant see any smoke in my rear view mirror or on tick over.

    The car smells of oil after I have been driving sometimes or just been driving quick and come to a set of lights.

    I removed the air filter and there is a bit of oil in there.

    Any idea what it is, Is it my turbo seals going???????????

  2. #2
    Status
    Offline
    clokey's Avatar
    AOC Gold Member
    Join Date
    May 2003
    Posts
    4,845
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    I think that if you can smell Burning Oil inside the car thats defo the Turbo.

    Hybrid here we come
    Astra Sri Turbo

    CS4 276BHP/325lbft


    LMF Vauxhall - 01858 433599

  3. #3
    Status
    Offline
    AndyGSi's Avatar
    AOC Fanatic
    Join Date
    Feb 2005
    Posts
    775
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It could be the turbo oil return pipe to the sump. I think this happened to AJmoirgls (apologies if I got the name wrong mate) he had the pipe changed by Vauxhall three times or so, before they gave up and fitted a new turbo under warranty, stating that the original turbo was defective.

    You could be lucky, or unlucky, depending if you are ready for the Hybrid or not??
    Astra GSi Turbo, SOLD


  4. #4
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Not really got £800 odd laying around for hybrid just yet but my car is an ex lease car and about 7k ago it says the turbo was replaced due to 'oil smell in cabin'

  5. #5
    Status
    Offline
    chewitt's Avatar
    AOC Obsessed
    Join Date
    May 2005
    Posts
    2,242
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    isnt this the 1 with 3 melted pistons???

  6. #6
    Status
    Offline
    ajmoirgls's Avatar
    AOC Regular
    Join Date
    Aug 2004
    Posts
    82
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It was me that did state that. Park it half on and half off a kurb stick you head under the front bumper in the middle and look up (whilst the engine is cold not hot - dont want to burn anything) there is a small hose that returns the oil from the turbo to the sump mine split several times and was replaced, but the turbo was at fault in the end. I had no oil in the airbox. The other sign was from the engine bay when you look down at the turbo to the top of the intercooler air hose where it attaches to the turbo was wet will oil in the seal. If its under warrenty get it checked asap.

    Good luck

    Alastair

  7. #7
    Status
    Offline
    grantr22's Avatar
    AOC Fanatic
    Join Date
    Aug 2004
    Posts
    306
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mine is doing this too, started after I fitted my de-cat pipe in place of the pre-cat. Less back pressure (no cat) means the turbo spins faster, but too fast and blows the seals out (or so I'm told). Oil drips from the turbo onto the hot exhaust which causes the burning smell when you stop. Needs new turbo, not repairable.

  8. #8
    Status
    Offline
    lee gsi's Avatar
    AOC Obsessed
    Join Date
    Jul 2003
    Location
    Near Portsmouth....... Drives a Signum 1.9 CDTi
    Posts
    17,757
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    So it does sound like my turbo seals are going???????

    Can you send of the turbo to have the seals replaced or do they only do recon turbos as mine boost's and runs fine. Just the smell and loosing oil problem

    Also I have no oil puddles where I park so maybe if that pipe is leaking its going on the exhaust and burning off straight away.

  9. #9
    Status
    Offline
    dannysport18's Avatar
    AOC Obsessed
    Join Date
    Sep 2003
    Posts
    35,241
    Mentioned in
    7 Post(s)
    Quoted
    7 Post(s)
    take it back to vauxhall when was the turbo done ???? there work should be covered for 1 year on parts ??

  10. #10
    Status
    Offline
    coupe_turbo_jon's Avatar
    AOC Obsessed
    Join Date
    May 2005
    Posts
    1,946
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Is this theaory true about the precat? or is this just a load of jibberish
    Astra Coupe Turbo Edition
    230bhp remap air and exhaust mods

Page 1 of 2 12 LastLast

Similar Threads

  1. Egg smell..........very strong fumey smell
    By edys129 in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 4
    Last Post: 05-07-2010, 22:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •