Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Telltale signs of dodgy AFM

  
  1. #1
    Status
    Offline
    tay's Avatar
    AOC Fanatic
    Join Date
    May 2004
    Posts
    609
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Telltale signs of dodgy AFM

    Peeps,

    I've looked through various posts about people and their stories of their AFM's breaking/failing on a regular basis - and have come to the conclusion that mine has probably gone as well. What I would like to know is are there any telltale signs that means it definately has ? The car doesn't have any warning lights on, but it just seems to me that it drives like a N/A 2.0. Its hard to explain, but it just doesn't pull as well as when i first bought it a year ago - you could feel the turbo comin on but now its as if it isn't there ! I have a Pipercross Viper induction kit (apparently these are AFM killers !?!), Courtney FMIC, Regal Pre-cat pipe, Regal Powerpipe, Full Bastuck exhaust on there so it shouldn't be short on power - I'm guessing around 220 ish ? and if anything I thought it would be pulling stronger than before.

    Sorry if this doesn't make sense - its kinda hard to explain !!!

    Any help would be much appreciated

    Cheers

    Tay

  2. #2
    Status
    Offline
    Raz's Avatar
    Technical Advisor
    Join Date
    Jan 2004
    Posts
    441
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Usually when the AFM has gone the car has trouble idling and is juddering all through the range. Power is down but the more noticble fact is the car runs really rough.

    Even if you go on Tech 2 it will come up NO TROUBLE CODES STORED

    Its a case of sitting and checking everything in Data Display.

  3. #3
    Status
    Offline
    Al's Avatar
    Turbo Jizz Golfer !
    Join Date
    May 2003
    Posts
    8,200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Mine was dead as a dodo according to regals on Saturday. However, there were no lights on the dash at the time and also the car seems to pull ok through 1-3, but 4 and 5 seems a bit sluggish. Also, the car does seem to judder a little in 5th. Tech2 did pick it up and my dynograph showed up. However, when I spoke to Vx themselves they said the engine management light will come on if the AMM is dead.

    Im now very confused too

  4. #4
    Status
    Offline
    tay's Avatar
    AOC Fanatic
    Join Date
    May 2004
    Posts
    609
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I'm thinking of buying a new one and trying that. by the looks of things even if it hasn't gone it will do at some point in time so at least i'll have a spare !!!

  5. #5
    Status
    Offline
    Raz's Avatar
    Technical Advisor
    Join Date
    Jan 2004
    Posts
    441
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    EML doesnt come on when amm goes.

    I get them all the time!

  6. #6
    Status
    Offline
    Al's Avatar
    Turbo Jizz Golfer !
    Join Date
    May 2003
    Posts
    8,200
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Raz
    EML doesnt come on when amm goes.

    I get them all the time!
    Now I am more confused. Someone must be telling me the truth here

  7. #7
    Status
    Offline
    tay's Avatar
    AOC Fanatic
    Join Date
    May 2004
    Posts
    609
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Milano S
    Now I am more confused. Someone must be telling me the truth here
    Same here mate !

    hows about we do a group buy on em - then everyone can have a spare to hand ???

  8. #8
    Status
    Offline
    AndyGSi's Avatar
    AOC Fanatic
    Join Date
    Feb 2005
    Posts
    775
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    There have been one or two occurances where the actuator rod have been fouled by the turbo heat shield, preventing the car boosting up. check to see that your rad has not pushed the heat shield onto the arm, this maybe an issue because the courtenay FMIC spaces the rad so far back, but it has happened on a standard car that I know of.


    Worth a look!
    Astra GSi Turbo, SOLD


  9. #9
    Status
    Offline
    Pete's Avatar
    Sir Peter Pan
    Join Date
    May 2003
    Posts
    9,862
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by Raz
    Usually when the AFM has gone the car has trouble idling and is juddering all through the range. Power is down but the more noticble fact is the car runs really rough.

    Even if you go on Tech 2 it will come up NO TROUBLE CODES STORED

    Its a case of sitting and checking everything in Data Display.
    I disagree, I`ve had 3 AFM`s and each time the management light has come on, and tech 2 shows the AFM as reading zero, but my car seems to go better
    Also keep a close eye on the rev counter at idle, it`ll bounce ever so slightly if the AFM has gone.
    My Project Auto-Biography Thread: Skin of an Astra - Heart of a Monaro - Click here to read more!

  10. #10
    Status
    Offline
    clokey's Avatar
    AOC Gold Member
    Join Date
    May 2003
    Posts
    4,845
    Mentioned in
    0 Post(s)
    Quoted
    1 Post(s)
    Have to agree with Pete too, ive also had about 3 in the past year and a half.

    Tech 2 reading 0 or "Not Present" also my TC light comes on and the car does go better
    Astra Sri Turbo

    CS4 276BHP/325lbft


    LMF Vauxhall - 01858 433599

Page 1 of 2 12 LastLast

Similar Threads

  1. Telltale alarm LED
    By rodsfromday in forum Electrical
    Replies: 5
    Last Post: 16-05-2010, 21:07
  2. Cruise control telltale
    By KrisC in forum Electrical
    Replies: 5
    Last Post: 18-11-2008, 18:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •