Results 1 to 6 of 6

Thread: Warning lights!!

  
  1. #1
    Status
    Offline
    Deano7's Avatar
    AOC Newbie
    Join Date
    Jun 2005
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Warning lights!!

    Hi all,

    I have posted this in the technical section but thought I would try it here too:

    Question from a newbie! I have just bought a 2.0L Astra SRI (W reg) and I have an intermittent problem with my TC and ABS lights coming on, this is in conjunction with an erratic speedo flicking from 0-10mph (at standstill!). I know the sensor is common to a hub which I believe is the passenger front. I have had this replaced at a cost of £180 (just for the hub!) but it has made no difference! Is there another speed probe or is it only on the front passenger wheel? I have took it into the main Vauxhall dealer but unfortunately the error wasn't standing at the time (another £40 wasted!). I have read on the forum other peoples experiences of this but never seen a definitive answer. This appears to be a common problem. Any information or answers much appreciated.
    Thanks in advance.

  2. #2
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    I got the same problem on mine. When I was at Regal back in Feb, they cleared the fault codes with tech2 and it was fine for a little while. But I never fixed the cause so it's back. Might just need resetting.

    Or perhaps the hub has been replaced and not the sensor?
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  3. #3
    Status
    Offline
    Deano7's Avatar
    AOC Newbie
    Join Date
    Jun 2005
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Yes possibly? I didn't see the hub but was assured that it had the abs/speed sensor combined and you would think at £180 it would have too!

    When I start the car I would say 60% of the time the speedo will flick and then I will hear the TC try to work (Humming type noise) theb the TC light will flash followed by the ABS light coming on. Very annoying as this is a safety feature of the car. Am considering contacting Vauxhall over it as it does seem to be a common thing, at only 40000miles I don't think it very good to be honest.

  4. #4
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    mine happened after I spun out on a roundabout and clipped a curb. but we all do silly things once in a while.

    I would hope your hub included the sensor too! That's a lot of money. Who did the work, vx?
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

  5. #5
    Status
    Offline
    Deano7's Avatar
    AOC Newbie
    Join Date
    Jun 2005
    Posts
    10
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    It was a local garage that I use regular so I trust them. Just at a loss as to what to try next. Does anyone know if the Astra 4 SRI only has 1 speed sensor?

    Perhaps I need to replace another?

  6. #6
    Status
    Offline
    Jace's Avatar
    AOC Gold Member
    Join Date
    Oct 2004
    Posts
    11,472
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    there's gonna be at least 2, one on each side I would've thought. I know my front left needs replacing cos that's the one that hit the kirb!
    From the Southeast? Find your next meet here


    The difference between intelligence and stupidity is that intelligence is limited.

    At least I have chicken!

    WellOilBeefHooked

Similar Threads

  1. Warning lights
    By wolfiessam in forum Astra Discussion & Chat
    Replies: 3
    Last Post: 07-04-2010, 19:37
  2. Warning lights
    By Manne in forum Electrical
    Replies: 1
    Last Post: 05-08-2007, 20:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •