Results 1 to 2 of 2

Thread: Engine Cooling Light

  
  1. #1
    Status
    Offline
    kakourdos's Avatar
    AOC Regular
    Join Date
    May 2003
    Posts
    296
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Unhappy Engine Cooling Light

    Hello,

    The eingine cooling light starting coming on and off today... it would come up for 1-4 seconds at a time at irrecular intervals.

    The oil temp was at a healthy range 80-85 C (was -2C outside this morning).
    I had a new thermostat fitted in June, a new water pump fitted in August.
    I have checked the water level and is unchanged since the water pump change.
    The fans kick in alright, the cabin heating works.
    I can't think of anything else, am very close to the point of getting rid of it.
    Help!

    1.6 16v (X16XEL) LS 5Door Petrol Manual Treg 1999 (with clutchless A/C pump, due to get a new pump in).

    Ciao,
    Kakourdos
    Unts! Unts! Unts!

  2. #2
    Status
    Offline
    kakourdos's Avatar
    AOC Regular
    Join Date
    May 2003
    Posts
    296
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Hello,

    I had a closer look, and noticed that one of the brackets on the radiator, somehow (really, I can't figure this out), is broken. the right-mid-top one as you face the front of the car, causing excesive play on the radiator...

    Any speculations on what may possibly happen with such play?
    At motorway speeds the cooilng light does not turn on at all. only when slowing down below 40mph.

    Second question. is there a chance the bracket comes as a separate part?

    Cheers,
    Kakourdos
    Unts! Unts! Unts!

Similar Threads

  1. Replies: 1
    Last Post: 17-11-2009, 14:38
  2. Engine cooling light?
    By CHRIS SLOAN in forum NA Engines (Non-turbo petrol) inc. Transmissions
    Replies: 3
    Last Post: 12-11-2005, 21:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •