Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: coupe turbo idle problem

  
  1. #1
    Status
    Offline
    wish2be's Avatar
    AOC Newbie
    Join Date
    Nov 2004
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    coupe turbo idle problem

    hello. the idle is irregular on my turbo z20let the revs drop then return to normal every mabye 20 secs has anybody had similar fault but tickover ok when some electrics swithced on i.e aircon etc

  2. #2
    Status
    Offline
    Autosparks's Avatar
    Technical Advisor
    Club Team
    Join Date
    May 2003
    Drives
    VXR Nurburgring
    Location
    N/W London
    Posts
    39,745
    Mentioned in
    115 Post(s)
    Quoted
    70 Post(s)
    I think I know what your on about and mine does exactly the same.

    Always on warm up though where you can be sitting at a set of lights and notice the engine revs drop 50/100 RPM briefly

    No idea why it does it but your not alone
    Want a professional job done on fitting your aftermarket electrical accessories? PM me for a quote
    Electrical fault finding also taken on
    Located in N/W London HA3, and willing to travel within reason





  3. #3
    Status
    Offline
    LordNikon's Avatar
    AOC Gold Member
    Join Date
    Jun 2003
    Posts
    18,952
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like its just constantly hunting for the correct idle. Being electronically monitored and controlled, I would take it back for a Tech2 update ... surprising what it could fix

  4. #4
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Re: coupe turbo idle problem

    Quote Originally Posted by wish2be
    hello. the idle is irregular on my turbo z20let the revs drop then return to normal every mabye 20 secs has anybody had similar fault but tickover ok when some electrics swithced on i.e aircon etc
    same here.
    I've only changed backbox and panel filter.
    sometimes car shut down and check engine light lights up ...
    I've noticed it happens only with warm engine in city traffic, and only sometimes, depending on I don't know what ...

  5. #5
    Status
    Offline
    turbodave's Avatar
    AOC Newbie
    Join Date
    Nov 2004
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My Coupé Turbo does exactly the same... any ideas to solve it?

  6. #6
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    I'd recommend changing the plugs to NGK Iridium BKR6EIX-11, you wont regret it
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  7. #7
    Status
    Offline
    turbodave's Avatar
    AOC Newbie
    Join Date
    Nov 2004
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Quote Originally Posted by devious dave
    I'd recommend changing the plugs to NGK Iridium BKR6EIX-11, you wont regret it
    will them really solve my idle problem?

    ThX!

  8. #8
    Status
    Offline
    d dave's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Location
    Edinburgh
    Posts
    11,579
    Mentioned in
    0 Post(s)
    Quoted
    5 Post(s)
    Add d dave on Facebook
    Well I know of a few people who had this problem, then changed to the said plugs and now havent had the problem anymore.
    Scottish Member? Have a peep at our Region For tints or wraps Click Here!!

  9. #9
    Status
    Offline
    turbodave's Avatar
    AOC Newbie
    Join Date
    Nov 2004
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    oK thanks Dave... I wil try with the NGK stuff... now I'm using the Bosch stock ones...

  10. #10
    Status
    Offline
    luke79's Avatar
    AOC Regular
    Join Date
    Jul 2003
    Posts
    140
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    hey Dave, are the Regal one (http://www.regal-shop.co.uk/asps/Sho...ls.asp?id=3841) the good ones ?

Page 1 of 3 123 LastLast

Similar Threads

  1. Turbo Coupe Idle Problem HELP!!!
    By Turnerator in forum Turbo Petrol Engines inc. Transmissions
    Replies: 5
    Last Post: 19-02-2014, 22:02
  2. Astra coupe turbo idle problem
    By Daniel 2.0 turbo in forum Turbo Petrol Engines inc. Transmissions
    Replies: 25
    Last Post: 29-08-2012, 21:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •