Results 1 to 3 of 3

Thread: Motorway Engine Management Light

  
  1. #1
    Status
    Offline
    hgandh0013's Avatar
    AOC Newbie
    Join Date
    Sep 2004
    Posts
    1
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Motorway Engine Management Light

    Guys,

    Just been having this problem. Driving to work as soon as I hit the motorway over 70 mph engine management light come on and stays on until I come off at the junction and get to about 50 mph.

    Anyone got any clues??

    Dont fancy doing a tech 1 had two done in the past four months. :roll:

    Cars a S reg 1.8 16v Sport.

    Cheers

    Hiren

  2. #2
    Status
    Offline
    Sku221e's Avatar
    AOC Regular
    Join Date
    Aug 2004
    Posts
    209
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    i would suggest it is your EGR valve as its exactly the symptoms i got.

    Doesnt effect the driving though does it... and then 1 day... sploodge... ya car will be a sack of knackers.

    Go to vaux have it teched again as a fault will be logged.. then decide on paying their stupid high prices or go somewhere else but use vaux to find out for sure.

  3. #3
    Status
    Offline
    Truemiccontrol's Avatar
    AOC Newbie
    Join Date
    May 2011
    Posts
    4
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    Astra 2002 1.7 dti Engine management Light

    Quote Originally Posted by Sku221e View Post
    i would suggest it is your EGR valve as its exactly the symptoms i got.

    Doesnt effect the driving though does it... and then 1 day... sploodge... ya car will be a sack of knackers.

    Go to vaux have it teched again as a fault will be logged.. then decide on paying their stupid high prices or go somewhere else but use vaux to find out for sure.
    Hi can i ask,
    if there is a problem with or egr valve needs cleaning does this come up as a specific code on a vauxhall dealers diagnostics. I have had it diagnosed at vauxhall and one code was stored in ecu which they said came up as critical engine problem, they have said that maybe something is sticking inside turbo or that a turbo pipe was split and possibly the turbo wasnt producing enough boost or too much, are they blagging me as the symptons im havin match the ones for egr valve problems?? the only problem i can visually see is that the intercooler is slightly leaking oil from the top, they said that it could also be the problem £217 = vat for an intercooler and fitting but im trying to get a 2nd hand one and fit it myself as it doesnt look too dificultI am also having this problem but the engine management light does not go off unless i pull over and wait a few mins, Switch off then when i switch it back on the light goes off and car drives ok. When it idles it sounds a bit rough but once the revs increase it sounds ok, it happens when i hit 75-85 mph it is a 1.7 dti 2002 model Astra Van, it also seems a bit picky about what gear it is in, it starts fine and runs fine, just have to make sure i dont go over 70

    any help would be greatly appreciated

    Dan

Similar Threads

  1. 1998 2.0 td engine cut out on motorway lost coolant and no glow plug light
    By maglite in forum Diesel Engines inc. Transmissions
    Replies: 3
    Last Post: 10-01-2010, 22:37
  2. Replies: 2
    Last Post: 31-08-2009, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •