Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: ENGINE MANAGEMENT light!!! car seriously SLOW!! PLEAS HELP!!

  
  1. #1
    Status
    Offline
    slicks's Avatar
    AOC Fanatic
    Join Date
    Oct 2003
    Posts
    349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    ENGINE MANAGEMENT light!!! car seriously SLOW!! PLEAS HELP!!

    my cars a T plate(99) Mk4 2.0 ls Di Astra (5 Door). my cars got a serious problem. it stuggles to keep up to 60-70mph on the motorway. and when the cars going uphill it has next to no power at all. :roll: i took it to vauxhall and they told me they couldn't find any fault codes (as the engine management light is not always on). so i took it to a cowboy mechanic who had one of them vauxhall computers. he hooked it up and told me that the sensors that were turning the light on are the airflow sensor and the speed sensor.

    someone told me that the cars got a restriction on it because it's an ex instructors car - this shouldunt effect the engine management light should it. and it shouldnt make the car struggle up hills should it.

    Does anyone have any idea what might be wrong with my car?? Please help

  2. #2
    Status
    Offline
    stevenlcroucher's Avatar
    AOC Obsessed
    Join Date
    May 2003
    Posts
    2,388
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    The airflow sensor is easy enough to change yourself, might be worth cleaning it first though to see if it makes a difference.

  3. #3
    Status
    Offline
    Amrik's Avatar
    AOC Fanatic
    Join Date
    May 2003
    Posts
    482
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    how do u clean the air flow sensor???

  4. #4
    Status
    Offline
    nasayr's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    you bum, y didnt u tell me your on this board?
    guess who...
    "Don't waste your time on jealousy. Sometimes you're ahead, sometimes you're behind. The race is long, and in the end it's only with yourself"

  5. #5
    Status
    Offline
    nasayr's Avatar
    AOC Obsessed
    Join Date
    Jun 2003
    Posts
    1,349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    basically his car dont rev over 3-4k, iv driven his car, you can wheel spin, dip the clutch when bootin it, and it will still stick to its limit, i even took the pipe off before the airflow and it was still restricted, so i doubt air flow meter,

    please help this guy, as he's sick of gettin the piss taken outa him
    "Don't waste your time on jealousy. Sometimes you're ahead, sometimes you're behind. The race is long, and in the end it's only with yourself"

  6. #6
    Status
    Offline
    slicks's Avatar
    AOC Fanatic
    Join Date
    Oct 2003
    Posts
    349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    the restrictions got nuthin to do with the engine management light. evan if it is restricted the light should not be cumin on. the car was alright a couple of months ago it has only recently got really sluggish, im guessin because of the light.

    airflow sensor and speed sensor!

    how do you take the restrictions off?

  7. #7
    Status
    Offline
    adamduk's Avatar
    AOC Fanatic
    Join Date
    Jul 2003
    Posts
    806
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    Limp Mode?

  8. #8
    Status
    Offline
    slicks's Avatar
    AOC Fanatic
    Join Date
    Oct 2003
    Posts
    349
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    if it is limp mode, how do i get it off? iv tried takin the batery off over night. didnt help though

  9. #9
    Status
    Offline
    Astra Dti 16v's Avatar
    AOC Newbie
    Join Date
    Jun 2003
    Posts
    36
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    sounds like same problem as mine. Lost the power, turned out to be the air flow meter. Common fault on 2.0 Di 16v's and Dti 16v's. Pricey though, got mine sorted under warranty.

  10. #10
    Status
    Offline
    Markh's Avatar
    AOC Regular
    Join Date
    Aug 2003
    Posts
    112
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    My Wife's car had the light on and crap performance, the fault code showed the air flow sensor. Got one from Autovaux for 93 quid plus VAT. I was talking to a guy at Bosch who said they are selling loads as Diesel buggers up the metal wire.

    Takes about five mins to fit and you can feel the difference after.

Page 1 of 2 12 LastLast

Similar Threads

  1. HELP. Traction Control light and Engine Management light on :-(
    By djcowely in forum Astra Discussion & Chat
    Replies: 7
    Last Post: 29-11-2009, 00:33
  2. Replies: 2
    Last Post: 31-08-2009, 21:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •