Results 1 to 2 of 2

Thread: ABS and Traction Control Lights

  
  1. #1
    Status
    Offline
    wanderer's Avatar
    AOC Newbie
    Join Date
    May 2003
    Posts
    40
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)

    ABS and Traction Control Lights

    Can any of you shed some light on this please?

    I set off rather quickly from some traffic lights the other night and now the ABS and traction control lights on the dash are lighting up. They stay on when i turn the engine on but if i drive for a while then turn the engine off and start it up again they go out.

    Anyone any ideas? Suppose it'll be a tech 2 won't it?

    I have a 2000/X 2.0 SRI by the way.

  2. #2
    Status
    Offline
    lotus astra's Avatar
    AOC Fanatic
    Join Date
    May 2003
    Posts
    544
    Mentioned in
    0 Post(s)
    Quoted
    0 Post(s)
    its a ****ed abs sensor in one of the wheels. Vaux will be able to tell which whell. Unfortunately, it means a new hub as the sensors are built in to the hubs. They have probably just got caked in crud. I removed all of wheels, and cleaned each connection to the sensor on the back side of the hubs. Then made sure all of my wheels were set to the correct torque setting, and off i went. No lights!!!! Bingo!

    If it stays on after this, its a replacement about £130 i think! Keep the warranty receipt for the part, as all the hubs have the same part number, so when another one does go, (within a year) you can replace it under warranty!!

    HTH

Similar Threads

  1. EML and traction control lights on
    By Pllusy in forum Turbo Petrol Engines inc. Transmissions
    Replies: 5
    Last Post: 23-04-2013, 18:58
  2. Replies: 3
    Last Post: 15-03-2012, 18:56
  3. Replies: 4
    Last Post: 23-07-2008, 16:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •